Detect when account email has changed, and update local state on iOS to match

RESOLVED FIXED

Status

()

enhancement
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: vbudhram, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MobileCore][FxA])

Reporter

Description

2 years ago
Similar to https://bugzilla.mozilla.org/show_bug.cgi?id=1383663, with the coming ability of users to change their primary email address, we should be able to update the local state of the account in the app.

Currently, whenever a user changes their display name or avatar, a push notification is sent to notify corresponding clients up fetch the new data. In addition, if push fails or user declined it, FxiOS should be able to request updated profile data from the profile server and update the interface accordingly.

Stefan, is there any other references to a user's email that might also need to be updated, configs etc?
Adding as blocker to the metabug
Blocks: 1364676
Reporter

Comment 2

2 years ago
This was fixed as part of https://bugzilla.mozilla.org/show_bug.cgi?id=1382756. The updated email will appear when user opens settings panel.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1174019
You need to log in before you can comment on or make changes to this bug.