Closed Bug 1384278 Opened 2 years ago Closed 2 years ago

Move metadata tables back into browser.db

Categories

(Firefox for iOS :: Data Storage, enhancement, P1)

Other
iOS
enhancement

Tracking

()

RESOLVED FIXED
Iteration:
1.26
Tracking Status
fxios 8.1+ ---

People

(Reporter: justindarc, Assigned: justindarc)

References

Details

(Whiteboard: [MobileCore][DataLoss])

Attachments

(1 file)

It seems that attaching a separate metadata.db for metadata storage has caused several regressions some of which are still unknown. In order to keep our sanity, we should move these tables back into browser.db.
This will be effectively undoing the work done in Bug 1339824.
Assignee: nobody → jdarcangelo
Blocks: 1339824
Status: NEW → ASSIGNED
Iteration: --- → 1.26
Priority: -- → P1
Whiteboard: [MobileCore]
Attached file GitHub Pull Request
Just a heads up, I removed all mentions of `AttachedTableX`, so the old migrations v22, v23 and v24 simply refer to the regular `TableX` variants. This seems fine since they start with `DROP TABLE IF EXISTS`, but I wanted to make mention of it here. I also tested this going from 8.0.1 (master) to this patch and everything seems to be working correctly now. It went from 15/17 tables expected to 17/17 on the first run.
Attachment #8890063 - Flags: review?(rnewman)
Whiteboard: [MobileCore] → [MobileCore][DataLoss][needsuplift]
Comment on attachment 8890063 [details] [review]
GitHub Pull Request

r+ with simplification.
Attachment #8890063 - Flags: review?(rnewman) → review+
Landed on master:

https://github.com/mozilla-mobile/firefox-ios/commit/0d116764bc29156553b23298102ad3d839b96d05

Landed on v8.x:

https://github.com/mozilla-mobile/firefox-ios/commit/59590c00906b96c59026ac9e1a5402fa73ba5d10
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Whiteboard: [MobileCore][DataLoss][needsuplift] → [MobileCore][DataLoss]
You need to log in before you can comment on or make changes to this bug.