If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Useless vertical scrollbar when one single row section enabled (top stories or empty highlights)

VERIFIED FIXED in Firefox 57

Status

()

Firefox
Activity Streams: Newtab
VERIFIED FIXED
2 months ago
9 days ago

People

(Reporter: asa, Assigned: Mardak)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 verified)

Details

(Reporter)

Description

2 months ago
On New Tab Page with Top Stories enabled I see a vertical scrollbar. 

Tested on latest Windows 10 Nightly build. Screen Resolution 3000x2000 with scaling at 200%.
(Assignee)

Comment 1

2 months ago
As in the vertical scrollbars are useless (i.e., don't actually scroll)?

Or if that the page is scrollable, I don't think it's intended for the new tab page to be a single "page".
(Assignee)

Comment 2

2 months ago
I suppose might be useful to point out that during user testing, many users didn't realize they could scroll with activity stream..
(Reporter)

Comment 3

2 months ago
The scrollbar is useless. It only scrolls a few pixels. If there were more top stories, I'd understand but the three "just barely" fit and the scollbar is useless.
(Assignee)

Updated

2 months ago
(Assignee)

Updated

11 days ago
Summary: vertical scrollbar when top stories enabled → Useless vertical scrollbar when one single row section enabled (top stories or empty highlights)
(Assignee)

Updated

11 days ago
Duplicate of this bug: 1399406
(Assignee)

Comment 5

11 days ago
florian, what's the document.body.clientHeight of the page when maximized (console detached or on side) on reference hardware?
Flags: needinfo?(florian)
(In reply to Ed Lee :Mardak from comment #5)
> florian, what's the document.body.clientHeight of the page when maximized
> (console detached or on side) on reference hardware?

753
Flags: needinfo?(florian)
The screen resolution is 1920x1080.
And in "Scale and layout", the "Change the size of text, apps, and other items" drop down was at the "125% (Recommended)" value, ie. the default. If I set this to "100%", then document.body.clientHeight becomes 968 and I have no vertical scrollbar.
(Assignee)

Comment 9

10 days ago
Fixed by https://github.com/mozilla/activity-stream/pull/3466 to be uplifted via bug 1399970.
Assignee: nobody → edilee
Blocks: 1399970
Status: NEW → RESOLVED
Last Resolved: 10 days ago
Resolution: --- → FIXED
(Assignee)

Updated

10 days ago
Blocks: 1394533
(Assignee)

Updated

9 days ago
status-firefox57: affected → fixed
Target Milestone: --- → Firefox 57
The vertical scroll bar is no longer displayed when one single row is enabled with Top Stories or empty Highlights.
Verified as fixed using latest Nightly 57.0a1 Build ID 20170915100121, on Windows 10 x64 and Mac 10.12.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
You need to log in before you can comment on or make changes to this bug.