If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Black blocks appear randomly above text when scrolling

RESOLVED WORKSFORME

Status

()

Core
Layout
P4
normal
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Olivier Cahagne, Assigned: dcone (gone))

Tracking

({testcase})

Trunk
Future
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Mozilla Build ID: 2002041810 (trunk), have seen this bug for months.

Steps to reproduce:
1. Load URL http://actu.voila.fr/Article/article_hightech_020419094319.v1te153j.html
2. Scroll either with mouse wheel or scrollbar,
3. Sometimes you'll see black blocks as in upcoming screenshot.

This occurs on some few other sites but I often see this bug surfing on this
site http://actu.voila.fr/
Might be related: bug 101907.
I'm using a T22 with S3 chipset at 16bpp, latest drivers.
(Reporter)

Comment 1

16 years ago
Created attachment 79966 [details]
Screenshot with build 2002041810 (trunk) on Win2k
(Reporter)

Comment 2

16 years ago
Created attachment 79970 [details]
Background image used on this page (and upcoming testcase)
(Reporter)

Comment 3

16 years ago
Created attachment 79971 [details]
Reduce testcase (scroll many times, at various speeds, up and down until you see black blocks)
(Reporter)

Updated

16 years ago
Keywords: testcase

Comment 4

16 years ago
Changing QA Contact
QA Contact: petersen → moied

Updated

16 years ago
Priority: -- → P4
WFM: Using 2002050108 trunk build on WinXP. I can not get the black blocks to
appear.

Reassigning to Don.

moied@netscape.com: Can you try to reproduce this using a current build on
Win2K?. Thanks.
Target Milestone: --- → Future
Reassigning
Assignee: attinasi → dcone

Comment 7

16 years ago
This could also be related to bug 104992 or bug 111176
(Reporter)

Comment 8

16 years ago
Ian I don't think this is bug 104492 as I'm not using an ATI graphic card, but a
S3 Savage IX. Bug 111176: perhaps although the graphic glitch is definitely
different.
I'll see if disabling cursor & bitmap acceleration makes it working.
(Reporter)

Comment 9

16 years ago
Marking dupe of bug 115452, there's definitely an issue with Mozilla/GTK/Win32
and S3 Savage* graphic cards.
When disabling cursor & bitmap acceleration, there's no issue anymore.

*** This bug has been marked as a duplicate of 115452 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

16 years ago
Reopening as even driver 7.40.54 (which fixed bug 115452) didn't solve this one.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
WFM, 2002-08-24-04 trunk Linux
WFM, 2002-08-24-04 trunk Windows 2000

Olivier, can you still reproduce it with a current trunk build?
(Reporter)

Comment 12

15 years ago
wfm using build 2002083104 on Win2k (trunk) + S3 driver 7.40.54.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.