Right aligned (float: right) content with absolute width cannot be accessed

VERIFIED DUPLICATE of bug 138505

Status

()

--
minor
VERIFIED DUPLICATE of bug 138505
17 years ago
17 years ago

People

(Reporter: mikko.rantalainen, Assigned: attinasi)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020412
BuildID:    2002041217

If a block-level element has absolute width (like 500px) and it's right aligned
and viewport width is less than the absolute width of the element (500px) the
element's content cannot be accessed. When viewport is too narrow IE6 renders
all the elements in the test case exactly the same (right aligned looks like
left aligned).

Reproducible: Always
Steps to Reproduce:
1. Open attached test case
2. Resize browser window so that viewport width is less than 500px

Actual Results:  Content inside right aligned table or div is inaccessible
because scroll is allowed to right only. 

Expected Results:  Something like how IE6 renders this. There shouldn't be any
difference between left and right floated elements when viewport is narrower
than the element. Mozilla should get this right for other elements but tables,
too. Alternately, all the content should be accessible with scrollbar (scrolling
to left from normal position would feel really weird though.

Tested with W98se only, but I guess this applies to all platforms.
(Reporter)

Comment 1

17 years ago
Created attachment 79976 [details]
Test case for float:right bug (inaccessible content)

Resize browser window so that viewport is narrower than 500px.

*** This bug has been marked as a duplicate of 138505 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Keywords: testcase
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Changing QA Contact
QA Contact: petersen → moied

Comment 4

17 years ago
verified dup of 138505 -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.