[float]Horizontal Scroll Missing On Table Wider than Browser

RESOLVED DUPLICATE of bug 6976

Status

()

Core
Layout
P2
normal
RESOLVED DUPLICATE of bug 6976
16 years ago
16 years ago

People

(Reporter: Felix Miata, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

16 years ago
2002041808 OS/2 trunk
800 X 600

To reproduce:
1-Size browser to more than 680 pixels wide
2-Open any page
3-Open in same window or tab URL indicated
4-Size browser to considerably less than 680 pixels wide
5-Execute back
6-Execute maximize
7-Execute forward
8-Execute restore

Actual behavior:
1-Image links left of their following descriptions disappear
2-Horizontal scrollbar is missing when narrower than 680 pixels

Expected behavior:
1-Image links left of their following descriptions remain
2-Horizontal scrollbar appears when narrower than 680 pixels

Notes:
Subject seems to be poor design, and lacks doctype and charset statements, but
links should appear regardless.
(Reporter)

Comment 1

16 years ago
Created attachment 79999 [details]
Same URL with host bloat removed & doctype & charset added
(Reporter)

Comment 2

16 years ago
Created attachment 80014 [details]
Cleaner testcase

I added the missing closing tags, alt="", and other to make the page validate,
but when width too narrow, still no horizontal scroll, and still the images
disappear.
I cannot reproduce this with today's trunk linux nightly.  Is this OS/2-only?

Comment 5

16 years ago
I see this on Windows, but I don't need any special steps.

If I open the testcase in the browser and size it smaller, text goes off the
left and no scrollbar appears.

Comment 6

16 years ago
I recommend the "Cleaner testcase" to reproduce this.

All I had to do was open this page in a browser window and size it smaller and 
no horizontal scrollbar appeared.

Information was cut off on the left.

This was this morning Windows build - 2002041903
Assignee: jst → attinasi
Status: UNCONFIRMED → NEW
Component: DOM HTML → Layout
Ever confirmed: true
OS: OS/2 → All
QA Contact: stummala → petersen
Hardware: PC → All

Comment 7

16 years ago
I don't think this is related to bug 138455, that's going on about floated box
elements, but there's not a float to be seen anywhere here.

I've made a much simpler testcase, will attach in a mo.

I see the problem too, Win98SE, 1.0 RC1 (2002041711)

Comment 8

16 years ago
Created attachment 80083 [details]
simplified testcase

Just view it, and make the window narrower

Comment 9

16 years ago
Text of even more reduced testcase:

<html>
<head>
<title>bug 138505 testcase</title>
</head>
<body>
<table width="600" align="right">
<tr><td>
why does this long string disappear off the left hand side of the window, without 
showing a scrollbar, when you make the window narrow?
</td></tr>
</table>
</body>
</html>

Removing the align="right" on the table makes everything behave more normally.

Comment 10

16 years ago
Created attachment 80087 [details]
Very simplified testcase
Attachment #79999 - Attachment is obsolete: true
Attachment #80014 - Attachment is obsolete: true
Attachment #80083 - Attachment is obsolete: true
*** Bug 138455 has been marked as a duplicate of this bug. ***
n.b. "align" is implemented with floats in Mozilla.
Summary: Horizontal Scroll Missing On Table Wider than Browser → [float]Horizontal Scroll Missing On Table Wider than Browser

Comment 13

16 years ago
Changing QA Contact
QA Contact: petersen → moied

Updated

16 years ago
Priority: -- → P2
Target Milestone: --- → Future

Updated

16 years ago
Keywords: testcase

Comment 14

16 years ago
dupe of "create scrollbar for / allow scrolling to overflow top (above) / left
of container"

see also bug 185997

*** This bug has been marked as a duplicate of 6976 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.