lufthansa.com (lh.com) and www.miles-and-more.com (www.milesandmore.com) force Firefox users to fill out captcha to access sites

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
2 years ago
5 months ago

People

(Reporter: aryx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sitewait][serversniff])

If one opens http://www.lufthansa.com/ or http://www.miles-and-more.com/ in Firefox (happens both on 54 and 56.0a1) on Windows 8.1, the site says that they think that it is a visit by a robot / script / crawler and one has to complete a captcha to access the site. There is no such captcha in latest Google Chrome and Internet Explorer.
Yikes... this also happens in OSX.

Karl, Adam, Dennis... do any of you have contacts with Lufthansa? Something about their bot detection is mega wrong.
Flags: needinfo?(dschubert)
Priority: -- → P1
Flags: needinfo?(astevenson)
(argh, sorry. See question in Comment #1)

Spoofing as Chrome makes the bot-block go away.
Flags: needinfo?(kdubost)
Whiteboard: [needscontact][serversniff]
I do, but they may be in the wrong department. I will give it a try, though.
Flags: needinfo?(dschubert)
Done. He basically confirmed that he is in the wrong department, but he is able to create a ticket and send it over to the right people.
Whiteboard: [needscontact][serversniff] → [sitewait][serversniff]
note that UA sniffing at Lufthansa has been always a kind of an issue.
Bug 905120

Thanks a lot Dennis.
Flags: needinfo?(kdubost)
Great!
Flags: needinfo?(astevenson)
I'm not able to reproduce it anymore.

[Tested with:]
Browser / Version: Firefox Nightly 63.0a1 (2018-07-04)
Operating System: Windows 10 Pro
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED

Comment 8

5 months ago
Still happens with Safari. I hope they don't manage their Aircraft like their IT systems.
You need to log in before you can comment on or make changes to this bug.