cannot add card to addressbook

VERIFIED FIXED in M11

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: waterson, Assigned: hangas)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
To reproduce:

1. Create a new profile (e.g., delete c:\winnt\mozregistry.dat)
2. Open addressbook
3. Click 'new card', fill in required info.
4. Click 'ok'

Get asserts (and eventually crash) because Mork cannot open database. I walked
up the stack a bit and it looks like the filespec munging is broken: it's
trying to tell Mork to open the profile directory as a database, instead of a
db file _inside_ the profile directory.
(Reporter)

Updated

19 years ago
Blocks: 13444

Comment 1

19 years ago
Using today's build, 1999091408M11, Esther reproduced this on her Win98 system
and I've reproduced it using NT4.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11
(Assignee)

Comment 2

19 years ago
*** Bug 13846 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: chuang → hangas
Status: ASSIGNED → NEW
Target Milestone: M11

Comment 3

19 years ago
The address book uri passed into AddCardToDatabase() from js is wrong (should be
abdirectory://abook.mab, but now pass '...').
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

19 years ago
I spent some time with waterson this morning on this.  He has found the problem
and checked in a fix.  I am pulling and building now.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Target Milestone: M11
(Assignee)

Comment 5

19 years ago
Waterson's checkin fixed this problem.  Marking fixed.

Updated

19 years ago
QA Contact: lchiang → esther

Comment 6

19 years ago
Not sure if this is completely fixed.  Need to investigate more, but it looks
like you will crash if you add a card to an empty address book.  The next time
you add a card to that address book it doesn't crash.  Need to investigate more.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
Using 19991003M10 build on win98 and 19991001M10 build on mac and linux this is
fixed.  I can add a new card to an address book already populated and an address
book that has no cards.   Verified
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.