Closed Bug 1384813 Opened 4 years ago Closed 4 years ago

Going to about:preferences#privacy-reports, there is no header for the content.

Categories

(Firefox :: Preferences, defect, P1)

55 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 56
Tracking Status
firefox56 --- verified

People

(Reporter: evanxd, Assigned: evanxd)

References

Details

(Whiteboard: [photon-preference])

Attachments

(3 files)

Attached image screenshot.png
Going to about:preferences#privacy-reports, there is no header for the content.

STR:
1. Go to about:preferences#privacy-reports

Actual:
There is no header for the content. (see it in the attachment)

Expected
We might need to have a header for the content.
It might be a P3 bug, but let's triage it.
Blocks: 1365133
Assignee: nobody → evan
Status: NEW → ASSIGNED
Flags: qe-verify+
Priority: -- → P1
Target Milestone: --- → Firefox 57
Target Milestone: Firefox 57 → Firefox 56
Comment on attachment 8891194 [details]
Bug 1384813 - Show a header for "about:preferences#privacy-reports" content since we would like to show every content with a header.

Hi Tina,

Could you help review the UI change? See the change at the screenshot[1].

Thank you.

[1]: https://bug1384813.bmoattachments.org/attachment.cgi?id=8891195
Attachment #8891194 - Flags: ui-review?(thsieh)
Attachment #8891194 - Flags: review?(mconley)
Hi Mike,

Could you help review the patch?

Thank you.
Comment on attachment 8891194 [details]
Bug 1384813 - Show a header for "about:preferences#privacy-reports" content since we would like to show every content with a header.

Hey Evan,
Thanks for adding the header back! The header looks good to me.
However, I've noticed that the two Learn more position seems a bit weird to me. 

I'll r+ this UI review for the header part. Thank you!
Attachment #8891194 - Flags: ui-review?(thsieh) → ui-review+
Sure, we've already fixed that at Bug 1384812.

Thank you for reviewing, Tina.
Comment on attachment 8891194 [details]
Bug 1384813 - Show a header for "about:preferences#privacy-reports" content since we would like to show every content with a header.

https://reviewboard.mozilla.org/r/162420/#review167834

Thanks!
Attachment #8891194 - Flags: review?(mconley) → review+
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e94c43d92f18
Show a header for "about:preferences#privacy-reports" content since we would like to show every content with a header. r=mconley
https://hg.mozilla.org/mozilla-central/rev/e94c43d92f18
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
I have reproduced this bug in Nightly 56.0a1 (2017-07-26) (64-bit) in Linux(64bit).

I can verify that this bug is fixed in latest Nightly. 

Build ID 	20170731100325
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170726]
I have reproduced this bug on Nightly according to (2017-07-26)

Fixing bug is verified on latest Beta--
Build ID 	20170808170225
User Agent 	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0

Tested OS-- Windows7 32bit
QA Whiteboard: [bugday-20170726] → [bugday-20170809]
As this bug is verified as fixed in both linux(comment 11) and windows(comment 12), I am marking this bug as verified fixed.
Status: RESOLVED → VERIFIED
Whiteboard: [photon-preference][triage] → [photon-preference]
You need to log in before you can comment on or make changes to this bug.