Manage Share Providers icon is missing on Mac

RESOLVED FIXED in Firefox 57

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: dao, Assigned: hanbin.chang, Mentored)

Tracking

({good-first-bug})

Trunk
Firefox 57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [good first bug][lang=css])

Attachments

(2 attachments)

Reporter

Description

2 years ago
+++ This bug was initially created as a clone of Bug #1384895 +++

(In reply to Johann Hofmann [:johannh] from bug 1384895 comment #3)
> This works for me but I should mention that on OSX the button is just blank,
> before and after this patch.
Reporter

Comment 1

2 years ago
Probably just need to remove this rule:

http://searchfox.org/mozilla-central/rev/ad093e98f42338effe2e2513e26c3a311dd96422/browser/themes/osx/browser.css#1066-1069
Assignee: dao+bmo → nobody
Mentor: dao+bmo
Status: ASSIGNED → NEW
Keywords: good-first-bug
Whiteboard: [good first bug][lang=css]
Assignee

Comment 2

2 years ago
Hi, I am new to the community and I would like to work on this as my first bug.
I have the test/dev environment set up on the virtual machine.
Could you please give me some advice on how I should test this?
Regards,
Flags: needinfo?(dao+bmo)
Reporter

Comment 3

2 years ago
(In reply to hanbin.chang from comment #2)
> Hi, I am new to the community and I would like to work on this as my first
> bug.
> I have the test/dev environment set up on the virtual machine.
> Could you please give me some advice on how I should test this?
> Regards,

Hi. To test this, first put the share widget on the toolbar. The panel that opens from the button should have a gear icon in the top left corner.
Flags: needinfo?(dao+bmo)
Assignee

Comment 4

2 years ago
Oh okay, I was wondering since the problem only occurs in Mac, I wasn't sure how to test this.
My virtual environment runs on Linux, so I am not sure how to reproduce this on Linux.
Also, could you assign this to me if possible? Regards
Flags: needinfo?(dao+bmo)
Reporter

Comment 5

2 years ago
Yeah, you won't be able to see the problem on Linux. Do you want to work on this regardless?
Flags: needinfo?(dao+bmo)
Assignee

Comment 6

2 years ago
It appears to be a simple fix if I am not underestimating it, and I would like to still work on this upon some guidance and mentoring(bugfix is part of credit for my software engineering course). I do have a Mac machine and I would guess that I need to set up the testing environment on my Mac or VM that has OSX?

Regards,
Reporter

Comment 7

2 years ago
(In reply to hanbin.chang from comment #6)
> It appears to be a simple fix if I am not underestimating it, and I would
> like to still work on this upon some guidance and mentoring(bugfix is part
> of credit for my software engineering course).

How far along are you? Have you built Firefox? Have you modified browser/themes/osx/browser.css as needed?

> I do have a Mac machine and I
> would guess that I need to set up the testing environment on my Mac or VM
> that has OSX?

I can get you a Mac build from automation once we have a patch.
Assignee: nobody → hanbin.chang
Status: NEW → ASSIGNED
Assignee

Comment 8

2 years ago
Hi, I have removed the line that you mentioned in an earlier reply and committed to my local repository.
Flags: needinfo?(dao+bmo)
Assignee

Comment 9

2 years ago
Reporter

Comment 10

2 years ago
Comment on attachment 8892133 [details] [diff] [review]
Bug 1384983 patchfile

Looks good. Thanks!
Flags: needinfo?(dao+bmo)
Attachment #8892133 - Flags: review+

Comment 11

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9f26b6d47e7f
Remove obsolete #manage-share-providers rule. r=dao
Assignee

Comment 12

2 years ago
Hi, what is the next step?
I am not entirely sure of the bugzilla process. Should I push the changes from my local repository?
Regards,
Flags: needinfo?(dao+bmo)
Reporter

Comment 13

2 years ago
(In reply to hanbin.chang from comment #12)
> Hi, what is the next step?
> I am not entirely sure of the bugzilla process. Should I push the changes
> from my local repository?
> Regards,

First contributors can't push to the integration repositories, see https://www.mozilla.org/en-US/about/governance/policies/commit/

I pushed the patch for you in comment 11. It should automatically be merged to mozilla-central within a day.
Flags: needinfo?(dao+bmo)
Assignee

Comment 14

2 years ago
Oh okay, thanks.

Comment 15

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9f26b6d47e7f
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
You need to log in before you can comment on or make changes to this bug.