Closed Bug 1385157 Opened 2 years ago Closed 2 years ago

can't set input focus to devtools console's "Filter output" field

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56- verified)

VERIFIED FIXED
Firefox 56
Iteration:
56.4 - Aug 1
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 - verified

People

(Reporter: cpeterson, Assigned: bgrins)

References

Details

(Keywords: regression, Whiteboard: [console-html])

Attachments

(1 file)

[Tracking Requested - why for this release]:

Sole, I think this bug is a regression from your fix for sdk/lang/functional bug 1378817.

STR:
1. Open devtools console.
2. Load a large web page like https://www.nytimes.com/
3. While the page is loading, click the devtools console's "Filter output" field with a mouse or trackpad.

RESULT:
The input focus is moved from the "Filter output" field to the >> prompt, preventing you filtering the console messages.

Setting focus to the "Filter output" field using the Ctrl+F keyboard shortcut seems to still work correctly.

I bisected this regression to this pushlog:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=cd19f7fa51603a562488956d30a1e75a740e79be&tochange=4e853e81c2be70c041fbae19e4e30dc7e97e86c2
Flags: needinfo?(sole)
Priority: -- → P2
Whiteboard: [console-html]
The regression seems more likely to be caused by https://bugzilla.mozilla.org/show_bug.cgi?id=1326937 , which is in that pushlog too.
Flags: needinfo?(sole)
Hi Chris

Double checked my patch, there were no changes on the console component:

https://reviewboard.mozilla.org/r/159332/diff/2#index_header

There are other console related checkins on that pushlog, we suspect that might be the cause. Nicholas is looking into that.
Whiteboard: [console-html] → [console-html] [triage]
Thanks Nicolas and Sole, bug 1326937 does look like a more likely cause of this console regression.

needinfo'ing bgrins, who fixed bug 1326937.
Blocks: 1326937
No longer blocks: 1378817
Flags: needinfo?(bgrinstead)
Thanks, I see the issue as well
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Flags: needinfo?(bgrinstead)
Iteration: --- → 56.4 - Aug 1
Flags: qe-verify?
Priority: P2 → P1
Whiteboard: [console-html] [triage] → [console-html]
Comment on attachment 8891445 [details]
Bug 1385157 - Don't focus jsterm if the output region wasn't clicked;

https://reviewboard.mozilla.org/r/162590/#review168216

The fix looks good to me.
Could we please add a test to make sure that clicking on the filter input won't focus the jsterm input too ?

::: devtools/client/webconsole/new-console-output/new-console-output-wrapper.js:50
(Diff revision 1)
>        if (event.detail !== 1 || event.button !== 0) {
>          return;
>        }
>  
> -      // Do not focus if something is selected
> -      let selection = this.document.defaultView.getSelection();
> +      // Do not focus if a link was clicked
> +      if (event.originalTarget.closest("a")) {

Nice
Flags: qe-verify? → qe-verify+
QA Contact: iulia.cristescu
Comment on attachment 8891445 [details]
Bug 1385157 - Don't focus jsterm if the output region wasn't clicked;

https://reviewboard.mozilla.org/r/162590/#review168430

Looks good, thanks Brian.
Attachment #8891445 - Flags: review?(nchevobbe) → review+
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/29ffe5a88b7b
Don't focus jsterm if the output region wasn't clicked;r=nchevobbe
https://hg.mozilla.org/mozilla-central/rev/29ffe5a88b7b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
I was able to reproduce the initial issue on 56.0a1 (2017-07-27). I can confirm the issue is fixed on 56.0a1 (2017-08-01), using Windows 10 x64, Ubuntu 16.04 x86 and Mac OS X 10.11.6.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
As it's verified, no need to track for 56.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.