Closed Bug 1385173 Opened 2 years ago Closed 2 years ago

Element.animate() will continually slow if call many times.

Categories

(Core :: DOM: Animation, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1253476

People

(Reporter: mantaroh, Unassigned)

References

()

Details

Attachments

(1 file)

Attached file dmd_report.txt
+++ This bug was initially created as a clone of Bug #1372642 +++

But #1372642 reported Web Animations slower than blink/gecko on stylo, but this phenomenon will occur on gecko as well.

This site use polyfill, however if UA support native API, this site use native implementation. 

The gecko will continually drop frame rate, and consume heap. In my macOS, gecko looks like to grow the heap.
This behavior might suggest to our that something will leak.

I took the profile:
 https://perfht.ml/2v78PQE

An attachment file is DMD report.
No longer blocks: stylo-perf
(In reply to Mantaroh Yoshinaga[:mantaroh] from comment #0)
> Created attachment 8891181 [details]
> dmd_report.txt
> 
> +++ This bug was initially created as a clone of Bug #1372642 +++
> 
> But #1372642 reported Web Animations slower than blink/gecko on stylo, but
> this phenomenon will occur on gecko as well.
> 
> This site use polyfill, however if UA support native API, this site use
> native implementation. 
> 
> The gecko will continually drop frame rate, and consume heap. In my macOS,
> gecko looks like to grow the heap.
> This behavior might suggest to our that something will leak.
> 
> I took the profile:
>  https://perfht.ml/2v78PQE
> 
> An attachment file is DMD report.

Sorry, The test case which I confirmed this phenomenon is wrong. I removed wrong fill mode from test case.
If I removed fill behavior from this test site, I can't reproduce this phenomenon. So this is  bug 1253476.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1253476
You need to log in before you can comment on or make changes to this bug.