Highlights item separators disappear from the top when scrolling down

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: mcomella, Assigned: sebastian)

Tracking

unspecified
Firefox 57
All
Android
Points:
---

Firefox Tracking Flags

(fennec+, firefox55 unaffected, firefox56 disabled, firefox57 verified)

Details

(Whiteboard: [mobileAS])

Attachments

(2 attachments)

Created attachment 8892112 [details]
Screenshot

STR:
- With enough highlights that you need to scroll...
- Scroll down to see more highlights

Expected: item separators remain
Actual: item separators disappear

I'm guessing our math is off when we remove the item decoration separators in the recyclerView for the Highlights title & friends.
Priority: P1 → --
No longer blocks: 1377247
Priority: -- → P3
(Assignee)

Updated

a year ago
Duplicate of this bug: 1388373
tracking-fennec: ? → +
(Assignee)

Updated

a year ago
Assignee: nobody → s.kaspari
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
(Reporter)

Comment 3

a year ago
mozreview-review
Comment on attachment 8905985 [details]
Bug 1385988 - HighlightsDividerItemDecoration: Use adapter position and not current position in parent view.

https://reviewboard.mozilla.org/r/177742/#review182848
Attachment #8905985 - Flags: review?(michael.l.comella) → review+
Iteration: --- → 1.29
Priority: P3 → P1

Comment 4

a year ago
Pushed by michael.l.comella@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ae513db6d626
HighlightsDividerItemDecoration: Use adapter position and not current position in parent view. r=mcomella
Duplicate of this bug: 1397885
https://hg.mozilla.org/mozilla-central/rev/ae513db6d626
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
status-firefox55: --- → unaffected
status-firefox56: --- → disabled
Verified this using the steps in Comment 0 on a Nexus 5 (Android 6.0.1).
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
You need to log in before you can comment on or make changes to this bug.