Closed Bug 1386011 Opened 2 years ago Closed Last year

Permafailing CCov builds failing with gmake[5]: *** [Unified_cpp_js_src0.o] Error 1

Categories

(Testing :: Code Coverage, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Needinfoing the patch authors for everyone in that merge.
Flags: needinfo?(sotaro.ikeda.g)
Flags: needinfo?(mcastelluccio)
Flags: needinfo?(janus926)
Flags: needinfo?(felipc)
My changes are in JavaScript only, so they can't be causing this.

I bet it's https://hg.mozilla.org/mozilla-central/rev/e94dceac80907abd4b579ddc8b7c202bbf461ec7.
Flags: needinfo?(mcastelluccio)
The error is:
/home/worker/workspace/build/src/js/src/builtin/Eval.cpp: In member function 'void EvalScriptGuard::lookupInEvalCache(JSLinearString*, JSScript*, jsbytecode*)':
/home/worker/workspace/build/src/js/src/builtin/Eval.cpp:103:10: internal compiler error: in make_ssa_name_fn, at tree-ssanames.c:136
     void lookupInEvalCache(JSLinearString* str, JSScript* callerScript, jsbytecode* pc)
(In reply to Wes Kocher (:KWierso) from comment #4)
> Try push with a backout of bug 1385181:
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=adb1611d86f8c82883fe34b45b453ec856babbb7&selectedJob=1
> 19775909

It's green.
Blocks: 1385181
Flags: needinfo?(felipc)
Flags: needinfo?(sotaro.ikeda.g)
Doesn't merit an automatic backout since CCov builds are tier-2, but it would be good to fix this before 56 merges to beta.
I think we should consider making the CCov builds tier-1. If we can't run the builds, we can't collect code coverage information and noticing coverage regressions becomes harder.
To me CCov has higher priority than bug 1385181, could you help back it out? Thank you.
Flags: needinfo?(janus926) → needinfo?(wkocher)
(In reply to Andrew McCreight [:mccr8] from comment #3)
> The error is:
> /home/worker/workspace/build/src/js/src/builtin/Eval.cpp: In member function
> 'void EvalScriptGuard::lookupInEvalCache(JSLinearString*, JSScript*,
> jsbytecode*)':
> /home/worker/workspace/build/src/js/src/builtin/Eval.cpp:103:10: internal
> compiler error: in make_ssa_name_fn, at tree-ssanames.c:136
>      void lookupInEvalCache(JSLinearString* str, JSScript* callerScript,
> jsbytecode* pc)

I and Ben Kelly saw the same problem.
Duplicate of this bug: 1385977
Fixed by the backout of bug 1385181.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.