Fix and enable the mochitest for bug 1053321 on Android

RESOLVED FIXED in Firefox 59

Status

()

enhancement
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mayhemer, Assigned: mayhemer)

Tracking

Trunk
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(1 attachment)

Before we have cycles to fix bug 1386194 it would be good to land the test at https://bugzilla.mozilla.org/attachment.cgi?id=8892597&action=edit disabled on android.  See https://bugzilla.mozilla.org/show_bug.cgi?id=1053321#c23 and c25 for details.
Note that we don't run wpt on Android yet anyway, so mochitest coverage is beneficial in that respect too.
Summary: Land mochitest for bug 1053321 → Fix and enable the mochitest for bug 1053321 on Android
Priority: -- → P2
I believe this has been fixed with Bug 1392382 and can now be enabled.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4943c9c6243b6f5875eb65f47a0b71dc2f2235e5
Flags: needinfo?(honzab.moz)
Flags: needinfo?(honzab.moz)
Status: NEW → ASSIGNED
Flags: needinfo?(honzab.moz)
The problem here is that from some reason we do the "unblock" requests two times on Android, always.  No idea why, but the sjs code has to count with that.
Posted patch v1Splinter Review
- there is no guarantee that an async scripts will run before onload in this case, fixed with explicit wait for both scripts to execute ; this was the root cause
- the sjs script is protected against duplicate requests for unblocking ; was another problem, but not root cause of the perma-failure

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ac23623d6a5a0ff0e0c02d71db60e27804d9f337
Attachment #8941847 - Flags: review?(bkelly)
Attachment #8941847 - Flags: review?(bkelly) → review+
thanks!
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/7fba47d2119b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.