[Form Autofill] Add "Learn more" links to SUMO pages in preferences

RESOLVED FIXED in Firefox 56

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: scottwu, Assigned: scottwu)

Tracking

(Blocks 1 bug)

unspecified
mozilla57
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(thunderbird_esr52 unaffected, firefox-esr52 unaffected, firefox55 unaffected, firefox56 fixed, firefox57 fixed)

Details

(Whiteboard: [form autofill:MVP])

Attachments

(3 attachments)

Assignee

Description

2 years ago
Add links to SUMO pages that tell users more about the form autofill features.

UX spec: https://mozilla.invisionapp.com/share/AP8TFZ22G#/screens/228643733
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 3

2 years ago
mozreview-review
Comment on attachment 8905829 [details]
Bug 1386922 - Add learn more link to autofill address,

https://reviewboard.mozilla.org/r/177638/#review182700
Attachment #8905829 - Flags: review?(lchang) → review+

Comment 4

2 years ago
mozreview-review
Comment on attachment 8905830 [details]
Bug 1386922 - Add learn more link to autofill credit card,

https://reviewboard.mozilla.org/r/177640/#review182702

::: browser/extensions/formautofill/locales/en-US/formautofill.properties:10
(Diff revision 1)
>  preferenceGroupTitle = Form Autofill
>  enableAddressAutofill = Autofill addresses
>  addressAutofillLearnMore = Learn more
>  savedAddresses = Saved Addresses…
>  enableCreditCardAutofill = Autofill credit cards
> +creditCardAutofillLearnMore = Learn more

Looks like we can use the same id (and split it when we need afterward).
Attachment #8905830 - Flags: review?(lchang) → review+
Assignee

Comment 5

2 years ago
mozreview-review-reply
Comment on attachment 8905830 [details]
Bug 1386922 - Add learn more link to autofill credit card,

https://reviewboard.mozilla.org/r/177640/#review182702

> Looks like we can use the same id (and split it when we need afterward).

Cool I'll do that.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment on attachment 8905829 [details]
Bug 1386922 - Add learn more link to autofill address,

https://reviewboard.mozilla.org/r/177638/#review183908

Thanks
Attachment #8905829 - Flags: review?(MattN+bmo) → review+
Comment on attachment 8905830 [details]
Bug 1386922 - Add learn more link to autofill credit card,

https://reviewboard.mozilla.org/r/177640/#review183938

::: browser/extensions/formautofill/locales/en-US/formautofill.properties:7
(Diff revision 2)
>  # License, v. 2.0. If a copy of the MPL was not distributed with this
>  # file, You can obtain one at http://mozilla.org/MPL/2.0/.
>  
>  preferenceGroupTitle = Form Autofill
>  enableAddressAutofill = Autofill addresses
> -addressAutofillLearnMore = Learn more
> +learnMore = Learn more

Please make this change and the related reference changes in part 1 to avoid the intermediate changes.

Flod confirmed he's fine with sharing this string for now.
Attachment #8905830 - Flags: review?(MattN+bmo) → review+
Assignee

Comment 10

2 years ago
mozreview-review-reply
Comment on attachment 8905830 [details]
Bug 1386922 - Add learn more link to autofill credit card,

https://reviewboard.mozilla.org/r/177640/#review183938

> Please make this change and the related reference changes in part 1 to avoid the intermediate changes.
> 
> Flod confirmed he's fine with sharing this string for now.

Yes, thanks for spotting this. This should be on the first patch.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Assignee

Comment 13

2 years ago
Checking this in. Thanks Matt and Luke.
Keywords: checkin-needed

Comment 14

2 years ago
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/834aca219fbb
Add learn more link to autofill address, r=lchang,MattN
https://hg.mozilla.org/integration/autoland/rev/70d1f53f21f2
Add learn more link to autofill credit card, r=lchang,MattN
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/834aca219fbb
https://hg.mozilla.org/mozilla-central/rev/70d1f53f21f2
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Comment on attachment 8905829 [details]
Bug 1386922 - Add learn more link to autofill address,

Approval Request Comment
[Feature/Bug causing the regression]: Form autofill Learn More links to help users. We had to wait for the SUMO team to give us a URL.
[User impact if declined]: No additional information for users about what autofill is
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no, I manually verified yesterday on a local build
[List of other uplifts needed for the feature/fix]: None for this fix
[Is the change risky?]: No
[Why is the change risky/not risky?]: just adding learn more labels
[String changes made/needed]: Yes, but in files not part of the usual l10n process so it doesn't affect localizers at this time
Attachment #8905829 - Flags: approval-mozilla-beta?
Comment on attachment 8905830 [details]
Bug 1386922 - Add learn more link to autofill credit card,

Approval Request Comment: See comment 16
Attachment #8905830 - Flags: approval-mozilla-beta?
Comment on attachment 8905829 [details]
Bug 1386922 - Add learn more link to autofill address,

New link to SUMO for new feature. Let's uplift this for beta 12.
Attachment #8905829 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
This needs rebased patches for Beta uplift.
Flags: needinfo?(scwwu)
Comment on attachment 8905830 [details]
Bug 1386922 - Add learn more link to autofill credit card,

Credit card support is not for 57 so I shouldn't have flagged this one.
Attachment #8905830 - Flags: approval-mozilla-beta?
Attachment #8905829 - Flags: approval-mozilla-beta+ → approval-mozilla-beta-
Attachment #8907866 - Attachment description: Beta patch → Beta patch (address only)
>  Attachment #8905829 [details] - Flags: approval-mozilla-beta+ → approval-mozilla-beta-

Was this from confusion due to comment 20? The address patch does still need uplift, just not the credit card one.
Flags: needinfo?(lhenry)
I see, yes, I misunderstood comment 20 to mean that we didn't need this uplifted. Ryan is working on it now.
Flags: needinfo?(lhenry)
Comment on attachment 8907866 [details] [diff] [review]
Beta patch (address only)

3rd time's the charm.
Attachment #8907866 - Flags: approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.