Duplicate newlines are removed from replies

RESOLVED DUPLICATE of bug 1385905

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1385905
7 months ago
6 months ago

People

(Reporter: Link @ QPG, Unassigned)

Tracking

55 Branch
Thunderbird 57.0

Thunderbird Tracking Flags

(thunderbird_esr52 unaffected, thunderbird55 wontfix, thunderbird56 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

826 bytes, application/x-extension-eml
Details
(Reporter)

Description

7 months ago
Created attachment 8893610 [details]
example.eml

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170612122310

Steps to reproduce:

Reply to a plain text message, leaving a blank line between paragraphs.


Actual results:

When sent, the newline characters on the blank lines are stripped from the message before it is sent removing the blank space between paragraphs.



Expected results:

The message should have been sent with a blank line (or lines depending on how many newline characters were present) between paragraphs.

Comment 1

7 months ago
Yes, this was fixed in bug 1385905 which started off as:
Thunderbird and SeaMonkey are removing blank lines from newsgroup replies
Thunderbird and SeaMonkey are removing blank lines from plaintext replies if replied about the moz-cite-prefix and when doubling up that div

You can verify this is a Daily build

We're in the process of releasing TB 56 beta, but it will still have that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1385905

Comment 2

7 months ago
TB 56 beta will be fixed, see bug 1385905 comment #26.
status-thunderbird55: --- → wontfix
status-thunderbird56: --- → fixed
status-thunderbird_esr52: --- → unaffected

Updated

7 months ago
Target Milestone: --- → Thunderbird 57.0

Comment 3

7 months ago
Created attachment 8894083 [details]
Don't forget to uplift M-C change to M-ESR52
Attachment #8894083 - Flags: approval-comm-esr52+

Comment 5

6 months ago
Comment on attachment 8894083 [details]
Don't forget to uplift M-C change to M-ESR52

My mistake, TB 52 is not affected.
Attachment #8894083 - Attachment is obsolete: true

Updated

6 months ago
Attachment #8894083 - Flags: approval-comm-esr52+
You need to log in before you can comment on or make changes to this bug.