nur48stunden.at - Menu is not displayed properly [HierMenus 4.0.8]

VERIFIED FIXED

Status

Tech Evangelism Graveyard
German
--
major
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: Walter Jaritz, Assigned: Tristan Nitot)

Tracking

Details

(Whiteboard: [havefix][TOOL][HIERMENU], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

The Javascript navigation flips down on Mouse over. On other browsers it flips
right when I choose a Menu Subitem from the flip down list. In Mozilla it pops
up elsewhere on the Page so I can't select the new items cause when I leave the
first flip down part of the menu to reach the pop'ed up menu part the menu closes.
This is not a new bug (but I think it should be fixed for 1.0 Final Release), it
also happend on older Mozilla versions.

Reproducible: Always
Steps to Reproduce:
load url www.nur48stunden.at and try to navigate with the menubar in the upper
part of the page.

Actual Results:  The second Menu Part pops up somehwere on page (same place all
the time)

Expected Results:  The second Menu part should pop up right of the first menu
part (like Windows StartMenu SubItems)

Comment 1

17 years ago
suggest Product: Tech Evangelism

Comment 2

17 years ago
To be more specific, submenus are not shifted correctly, but displayed totally
off, making it impossible to select a subitem.
[the page takes ages to load, oh well... don't we love webpages that try to be
full applications? ;.P}
Confirmed using 2002041609/BeOS/x86, latest nightly build as of 20/4/02.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
See also bug#138738 for another javascript-menu-related bug:
http://bugzilla.mozilla.org/show_bug.cgi?id=138738

Gregor
windows.event - ..isn't this MSIE only code?
Site uses HierMenus 4.0.8 which is very old.  They need to upgrade to a newer
hiermenus version that works with Mozilla.
Assignee: attinasi → nitot
Component: Layout → Europe: West
Keywords: qawanted
Product: Browser → Tech Evangelism
QA Contact: petersen → caillon
Summary: Javascript Menu is not displayed properly → Javascript Menu is not displayed properly [HierMenus 4.0.8]
Version: other → unspecified
(Reporter)

Comment 6

17 years ago
According to the website (http://www.webreference.com/dhtml/column51/),
HierMenus 4.0.8 should work with all Gecko Based Browsers..
hiermenus 4.0.8 doesnt work in newer version of moz because of a change in the
way we handle offsetLeft/Top properties.
see http://bugzilla.mozilla.org/show_bug.cgi?id=90617
setting as havefix, they just need to upgrade.
setting as blocking bug 85104
Blocks: 85104
Whiteboard: [havefix][TOOL][HIERMENU]

Comment 8

16 years ago
http://62.99.254.132/nur48stundenv2/javascript/menue/HM_ScriptDOM.js

The site has updated to HM 4.3, works in Mozilla 2003021103
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: qawanted
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → FIXED
Summary: Javascript Menu is not displayed properly [HierMenus 4.0.8] → nur48stunden.at - Menu is not displayed properly [HierMenus 4.0.8]

Comment 9

16 years ago
v
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → German
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.