Use Tiers instead of exclusion profiles

RESOLVED FIXED

Status

Tree Management
Treeherder
P1
normal
RESOLVED FIXED
9 months ago
4 months ago

People

(Reporter: camd, Assigned: camd)

Tracking

(Blocks: 2 bugs)

Details

Attachments

(3 attachments)

(Assignee)

Description

9 months ago
Some sub-bugs that should come from this bug are:

1. Stop applying a Tier to TaskCluster jobs based on exclusion profiles.  Just use the value that is specified in the task definition.  Tier-3 jobs are hidden.

2. Create a white or black list in the Treeherder codebase ETL layer for jobs from BuildBot that will be hidden.  These jobs will be set to Tier-3

3. Create a similar list for Buildbot Tier-2 jobs.  The only Buildbot Tier-2 jobs I can find on m-i, m-c and autoland are Autophone and Talos.  So this should be a pretty short list.

The proposal for this is a work-in-progress since it can have wide-ranging effects:
https://docs.google.com/document/d/1-BzCN97aCZKovWeh1zU6ASyp_FVtg0mbITN7C_iWXzg/edit#heading=h.dhpfyfxjvgg9
(Assignee)

Updated

9 months ago
Assignee: nobody → cdawson

Comment 2

9 months ago
Bug 1390192 is another example of how the new way will mean less confusion all around.

CCing Andrew, since it sounds like we all want the same thing:
https://groups.google.com/forum/#!topic/mozilla.tools.treeherder/ygqPmBob3Z0
(Assignee)

Comment 3

8 months ago
I'm going to start working on this bug this month, so bumping to P1.
Priority: -- → P1
(Assignee)

Updated

8 months ago
Blocks: 1397877
(Assignee)

Updated

8 months ago
No longer blocks: 1397877
Depends on: 1397877
(Assignee)

Updated

8 months ago
Depends on: 1398386
(Assignee)

Comment 4

8 months ago
The first PR for bug 1398386 will switch so the ingestion sets tiers for jobs, including Tier-3 for buildbot jobs that should be hidden.

The second PR will make the /jobs endpoint stop checking the exclusion profiles and remove the models for excluding.  It will also remove using the exclusion param from the UI.

Updated

8 months ago
Blocks: 1397716

Comment 5

8 months ago
Created attachment 8907260 [details] [review]
[treeherder] mozilla:remove-exclusion-profiles-2 > mozilla:master
(Assignee)

Comment 6

8 months ago
Comment on attachment 8907260 [details] [review]
[treeherder] mozilla:remove-exclusion-profiles-2 > mozilla:master

This will be followed up by a PR that removes all the models and tables for exclusion profiles.  I just wanted to leave them intact juuuuust in case there was a problem.
Attachment #8907260 - Flags: review?(emorley)

Comment 7

8 months ago
Comment on attachment 8907260 [details] [review]
[treeherder] mozilla:remove-exclusion-profiles-2 > mozilla:master

(In reply to Cameron Dawson [:camd] from comment #6)
> I just wanted to leave them intact juuuuust in case there was a problem.

Good idea :-)
Attachment #8907260 - Flags: review?(emorley) → review+

Comment 8

8 months ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/bde8e20f1f950c8edb953b1278b33575cc45da72
Bug 1387640 - Stop using exclusion profiles

Note: This leaves the models and tables intact so that we can
revert without data loss in case we discover an issue.  A follow-up
commit will remove those tables and models.

Updated

8 months ago
Blocks: 1178227

Updated

8 months ago
Status: NEW → ASSIGNED
Summary: [Meta] Use Tiers instead of exclusion profiles → Use Tiers instead of exclusion profiles

Comment 9

7 months ago
Created attachment 8908265 [details] [review]
[treeherder] mozilla:remove-exclusion-profiles-3 > mozilla:master
(Assignee)

Comment 10

7 months ago
Comment on attachment 8908265 [details] [review]
[treeherder] mozilla:remove-exclusion-profiles-3 > mozilla:master

Thanks for the previous pass.  I believe I addressed your concerns.
Attachment #8908265 - Flags: review?(emorley)

Comment 11

7 months ago
Comment on attachment 8908265 [details] [review]
[treeherder] mozilla:remove-exclusion-profiles-3 > mozilla:master

Looks great!

How long should we wait before merging this to stage and then prod?
Attachment #8908265 - Flags: review?(emorley) → review+
(Assignee)

Comment 12

7 months ago
I was thinking soaking PR2 for maybe 1 week.  I'm fairly certain we can address any non-hiddenness quickly enough that we won't need to re-enable exclusion profiles, but there's little hurry to remove the tables once they're not in use.  After 1 week and nobody is asking for my head, then I'll merge this latest PR.  :)

Comment 13

7 months ago
Created attachment 8909272 [details]
Exclusion profile export

I've exported the current exclusion profiles in case it's useful to refer back to them in the future (with a bit of editing to remove the chronic thousands of entries for the ~"all" case of the particular platform/...).

Now we have this export (which will help with figuring out why things were hidden/bug numbers etc), perhaps we can land the last PR here sooner than a few week away?
(Assignee)

Comment 14

7 months ago
Sure, sounds good to me!  Thanks for creating that export.  I'll go ahead and merge now.  :)

Comment 15

7 months ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/863f772a8b13bfb2039574937c0480b5b00c52d5
Bug 1387640 - Remove Exclusion Profiles models/tables

Removes all the models and tables for the ExclusionProfile and
JobExclusion models and related.
(Assignee)

Updated

7 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED

Updated

6 months ago
Duplicate of this bug: 1148674

Updated

4 months ago
Blocks: 1426962
You need to log in before you can comment on or make changes to this bug.