Enabling and disabling menu bar and restoring the window adds extra border to the top of the tab bar

RESOLVED DUPLICATE of bug 1387273

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 1387273
a year ago
10 months ago

People

(Reporter: Bruce, Unassigned)

Tracking

({regression})

57 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170804193726

Steps to reproduce:

0) Have a maximized window with the menu bar disabled.
1) Enable the menu bar.
2) Now disable it.
3) Restore the window.


Actual results:

There is a 3px accent coloured strip above the tab bar, and then a 1px tab-bar coloured strip above the tabs. See screenshot - http://i.imgur.com/wC6g0VA.png. (Note that my accent colour is that dark one)

Once your window gets stuck in the buggy mode, you can fix it by (following on from the original STR):

4) Enable the menu bar.
5) Disable it.


Expected results:

See screenshot - http://i.imgur.com/9va1ZZD.png.
(Reporter)

Updated

a year ago
Has STR: --- → yes
Component: Untriaged → Theme

Comment 1

a year ago
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0fdb6a37c65caaffbcf04834589c13bda0b96cd4&tochange=9aea49fa17a10967b4c28d7519ab1ea1ed27b9b6
Blocks: 1349555
Status: UNCONFIRMED → NEW
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox57: --- → affected
status-firefox-esr52: --- → unaffected
Ever confirmed: true
Keywords: regression
Whiteboard: [photon-visual] [triage]
No longer blocks: 1349555
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Whiteboard: [photon-visual] [triage]
Duplicate of bug: 1387273

Comment 3

10 months ago
Mirror the status of bug 1387273.
status-firefox57: affected → fixed
You need to log in before you can comment on or make changes to this bug.