Update more icons to the photon style

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: ntim, Assigned: ntim)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 57
Points:
---

Firefox Tracking Flags

(firefox57 verified, firefox58 verified)

Details

(Whiteboard: [reserve-photon-visual][p3])

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Subscribe, fullscreen (the standalone button, not the one in the menu), preferences, share, find in page need to be updated.
what about the little sound icon on the tabs?
Whiteboard: [photon-visual][triage]

Comment 2

2 years ago
There is a separate bug about the fullscreen button (1387613).
Duplicate of this bug: 1387613
Whiteboard: [photon-visual][triage] → [reserve-photon-visual][p3]
Flags: qe-verify?
Priority: -- → P3
Flags: qe-verify? → qe-verify+
QA Contact: brindusa.tot
Status: NEW → ASSIGNED
Priority: P3 → P1
Comment hidden (mozreview-request)

Comment 5

2 years ago
mozreview-review
Comment on attachment 8896742 [details]
Bug 1387784 - Update various icons to use photon style.

https://reviewboard.mozilla.org/r/168032/#review173934

The urlbar history dropmarker is already taken care of in bug 1389740 :/
Attachment #8896742 - Flags: review?(dao+bmo)
Comment hidden (mozreview-request)

Comment 7

2 years ago
mozreview-review
Comment on attachment 8896742 [details]
Bug 1387784 - Update various icons to use photon style.

https://reviewboard.mozilla.org/r/168032/#review176024

::: browser/themes/shared/identity-block/identity-block.inc.css:113
(Diff revision 2)
>  #urlbar[actiontype="searchengine"] > #identity-box > #identity-icon {
>    list-style-image: url(chrome://global/skin/icons/autocomplete-search.svg);
>  }
>  
>  #urlbar[actiontype="extension"] > #identity-box > #identity-icon {
> -  list-style-image: url(chrome://browser/skin/addons/addon-install-anchor.svg);
> +  list-style-image: url(chrome://browser/skin/addons.svg);

This file doesn't exist anymore, see bug 1389064

::: browser/themes/shared/menupanel.inc.css:5
(Diff revision 2)
>  /* Menu panel and palette styles */
>  
> -#appMenuRecentlyClosedWindows,
> +#appMenuRecentlyClosedWindows {
> +  list-style-image: url(chrome://browser/skin/window.svg);
> +}

Please move this rule to the bottom of this file

::: browser/themes/shared/urlbar-searchbar.inc.css:137
(Diff revision 2)
> +}
> +
> +#reader-mode-button[readeractive] {
> +  fill: var(--toolbarbutton-icon-fill-attention);
> +  fill-opacity: 1;
> +}

Please move this after the #pageActionButton rule at least
Attachment #8896742 - Flags: review?(dao+bmo)
Comment hidden (mozreview-request)

Comment 9

2 years ago
mozreview-review
Comment on attachment 8896742 [details]
Bug 1387784 - Update various icons to use photon style.

https://reviewboard.mozilla.org/r/168032/#review176032

Great work, thanks!
Attachment #8896742 - Flags: review?(dao+bmo) → review+
Duplicate of this bug: 1389646

Comment 11

2 years ago
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ff913409f74c
Update various icons to use photon style. r=dao
https://hg.mozilla.org/mozilla-central/rev/ff913409f74c
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Iteration: --- → 57.2 - Aug 29
QA Contact: brindusa.tot → ovidiu.boca
I want to verify this issue but I can't find the share icon, all the others are in customize. Tim, can you please tell me where I can find share icon? Thanks
Flags: needinfo?(ntim.bugs)
(Assignee)

Comment 14

2 years ago
Hi Ovidiu,

The description is outdated, the share icon has been removed now.
Here's a list of icons that have been updated by this bug:
- Subscribe
- Fullscreen
- Find in page
- Settings
- Recently closed windows (hamburger menu > library > history)
- Zoom icons
- Reader mode icons
- Findbar arrows

Thanks.
Flags: needinfo?(ntim.bugs)
Thanks Tim,

I verified this on Mac OS X 10.12, Windows 10, Ubuntu 16.04 with FF Nightly 58.0a1(2017-10-08) and Beta 57.0b6 and I can confirm the fixed. 

Tim, when you say "Settings" do you mean "Options" - on Win and "Preferences" - on Mac and Ubuntu? Thanks.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
status-firefox58: --- → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.