nightly 20170804 compile failed - error: ‘gfxAlphaType’ does not name a type

RESOLVED FIXED in Firefox 57

Status

()

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: stanl-mozilla, Assigned: jfkthame)

Tracking

57 Branch
mozilla57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8894378 [details]
custom .mozconfig that I am using

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170725113151

Steps to reproduce:

Updated hg repository to latest nightly version, compiled, got the error.  This is on an up to date Fedora 25.


Actual results:

20:05.42 In file included from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dom/bindings/OffscreenCanvasBinding.cpp:9:0,
20:05.42                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dom/bindings/UnifiedBindings12.cpp:50:
20:05.42 /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/dom/ImageBitmap.h:66:3: error: ‘gfxAlphaType’ does not name a type
20:05.42    gfxAlphaType mAlphaType;
20:05.42    ^~~~~~~~~~~~
20:05.42 /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/dom/ImageBitmap.h:203:15: error: ‘gfxAlphaType’ has not been declared
20:05.42                gfxAlphaType aAlphaType = gfxAlphaType::Premult);
20:05.42                ^~~~~~~~~~~~
20:05.42 /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/dom/ImageBitmap.h:275:9: error: ‘gfxAlphaType’ does not name a type
20:05.42    const gfxAlphaType mAlphaType;
20:05.42          ^~~~~~~~~~~~
20:05.42 /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/dom/ImageBitmap.h:203:41: error: ‘gfxAlphaType’ has not been declared
20:05.42                gfxAlphaType aAlphaType = gfxAlphaType::Premult);
20:05.42                                          ^~~~~~~~~~~~
20:05.42 /mnt/to_archive/accum/src/mozilla-central/config/rules.mk:1050: recipe for target 'UnifiedBindings12.o' failed
20:05.42 gmake[5]: *** [UnifiedBindings12.o] Error 1
20:05.42 /mnt/to_archive/accum/src/mozilla-central/config/recurse.mk:73: recipe for target 'dom/bindings/target' failed
20:05.42 gmake[4]: *** [dom/bindings/target] Error 2
20:05.42 gmake[4]: *** Waiting for unfinished jobs....


Expected results:

successful compile
Component: Untriaged → Graphics
Product: Firefox → Core
(Assignee)

Comment 1

a year ago
If you add

  #include "gfxTypes.h"

to the includes at the start of dom/canvas/ImageBitmap.h, does that resolve the problem?
Flags: needinfo?(stanl-mozilla)
(Reporter)

Comment 2

a year ago
Yes, that worked.
Flags: needinfo?(stanl-mozilla)
(Assignee)

Comment 3

a year ago
Created attachment 8894558 [details] [diff] [review]
Add missing #include to dom/canvas/ImageBitmap.h, to avoid build fragility (unified-compilation dependency)
Attachment #8894558 - Flags: review?(jmuizelaar)
(Assignee)

Updated

a year ago
Assignee: nobody → jfkthame
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8894558 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 4

a year ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/22734f3d4b603253f6e9ba1b4ff9bd36e4a73712
Bug 1387912 - Add missing #include to dom/canvas/ImageBitmap.h, to avoid build fragility (unified-compilation dependency. r=jrmuizel
(Assignee)

Updated

a year ago
Duplicate of this bug: 1389408

Comment 6

a year ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/65826179c86e
Add missing #include to dom/canvas/ImageBitmap.h, to avoid build fragility (unified-compilation dependency. r=jrmuizel a=stability
https://hg.mozilla.org/mozilla-central/rev/65826179c86e
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
(Reporter)

Comment 9

a year ago
Yes, nightly compiles fine with this fix.

Thanks.
You need to log in before you can comment on or make changes to this bug.