Intermittent TEST-UNEXPECTED-PASS | /hr-time/timeOrigin.html | Window timeOrigin is close to Date.now() when there is no system clock adjustment. | Window and worker timeOrigins are close when created one after another.

RESOLVED WORKSFORME

Status

P5
normal
RESOLVED WORKSFORME
a year ago
4 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

Version 3
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell disabled])

25 failures in 124 pushes (0.202 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 14
* mozilla-inbound: 6
* mozilla-central: 4
* try: 1

Platform breakdown:
* linux32: 25

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-07&endday=2017-08-07&tree=all
33 failures in 182 pushes (0.181 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 11
* mozilla-inbound: 8
* try: 6
* pine: 5
* mozilla-central: 3

Platform breakdown:
* linux32: 29
* windows7-32: 2
* linux64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-08&endday=2017-08-08&tree=all
See Also: → bug 1387924
Whiteboard: [stockwell needswork]
https://hg.mozilla.org/integration/mozilla-inbound/rev/d15a98cd17611ffce9511aee6987d4038a36f7e4 (bug 1386604) marked this as failing on linux32/debug. Unexpected passes, here and in bug 1387924, started shortly thereafter.
Blocks: 1386604
Flags: needinfo?(james)
19 failures in 156 pushes (0.122 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 11
* autoland: 6
* mozilla-central: 2

Platform breakdown:
* linux32: 19

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-09&endday=2017-08-09&tree=all
24 failures in 179 pushes (0.134 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 14
* mozilla-inbound: 7
* try: 2
* mozilla-central: 1

Platform breakdown:
* linux32: 24

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-10&endday=2017-08-10&tree=all
23 failures in 166 pushes (0.139 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 9
* autoland: 9
* mozilla-central: 5

Platform breakdown:
* linux32: 22
* linux64-ccov: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-11&endday=2017-08-11&tree=all
152 failures in 901 pushes (0.169 failures/push) were associated with this bug in the last 7 days. 

This is the #6 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 65
* mozilla-inbound: 46
* try: 18
* mozilla-central: 18
* pine: 5

Platform breakdown:
* linux32: 147
* windows7-32: 2
* linux64: 2
* linux64-ccov: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-07&endday=2017-08-13&tree=all
24 failures in 149 pushes (0.161 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 12
* mozilla-inbound: 5
* mozilla-central: 5
* try: 2

Platform breakdown:
* linux32: 22
* linux64-stylo: 1
* linux64-ccov: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-14&endday=2017-08-14&tree=all
I think this test is still being updated upstream. It seems like linux32 is by far the most unstable platform; I'm OK with just disabling it there for now.
Flags: needinfo?(james)
Summary: Intermittent TEST-UNEXPECTED-PASS | /hr-time/timeOrigin.html | Window timeOrigin is close to Date.now() when there is no system clock adjustment. - expected FAIL → Intermittent TEST-UNEXPECTED-PASS | /hr-time/timeOrigin.html | Window timeOrigin is close to Date.now() when there is no system clock adjustment. | Window and worker timeOrigins are close when created one after another.
Duplicate of this bug: 1387924
27 failures in 180 pushes (0.15 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 10
* mozilla-inbound: 7
* try: 5
* mozilla-central: 5

Platform breakdown:
* linux32: 24
* osx-10-10: 1
* linux64-stylo: 1
* linux64-ccov: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-15&endday=2017-08-15&tree=all
(In reply to James Graham [:jgraham] from comment #9)
> I think this test is still being updated upstream. It seems like linux32 is
> by far the most unstable platform; I'm OK with just disabling it there for
> now.

Note that it seems to become perma-pass when building with GCC6.
22 failures in 188 pushes (0.117 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 10
* mozilla-inbound: 5
* mozilla-central: 5
* try: 2

Platform breakdown:
* linux32: 18
* linux64-stylo: 3
* linux64-ccov: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-16&endday=2017-08-16&tree=all
28 failures in 194 pushes (0.144 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 11
* mozilla-inbound: 10
* mozilla-central: 4
* try: 3

Platform breakdown:
* linux32: 22
* windows7-32: 2
* osx-10-10: 1
* macosx64-stylo: 1
* linux64-stylo: 1
* linux64-ccov: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-17&endday=2017-08-17&tree=all
:jgraham, were you going to take care of disabling this test on linux32?
Flags: needinfo?(james)
43 failures in 160 pushes (0.269 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 24
* mozilla-inbound: 15
* try: 4

Platform breakdown:
* windows7-32: 26
* linux32: 13
* linux64-stylo: 2
* windows10-64: 1
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-18&endday=2017-08-18&tree=all
18 failures in 44 pushes (0.409 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 8
* mozilla-inbound: 7
* mozilla-central: 3

Platform breakdown:
* windows7-32: 16
* osx-10-10: 1
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-19&endday=2017-08-19&tree=all
200 failures in 949 pushes (0.211 failures/push) were associated with this bug in the last 7 days. 

This is the #5 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 92
* mozilla-inbound: 60
* mozilla-central: 31
* try: 17

Platform breakdown:
* linux32: 118
* windows7-32: 64
* linux64-stylo: 8
* osx-10-10: 4
* linux64-ccov: 4
* windows10-64: 1
* macosx64-stylo: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-14&endday=2017-08-20&tree=all
37 failures in 129 pushes (0.287 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 21
* mozilla-inbound: 9
* mozilla-central: 6
* try: 1

Platform breakdown:
* windows7-32: 31
* osx-10-10: 3
* windows7-32-stylo: 1
* windows10-64-stylo: 1
* windows10-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-21&endday=2017-08-21&tree=all

Comment 20

a year ago
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/dd0ce550bf64
Disable hr-time test on linux32 for instability, a=testonly
Done.
:jgraham, would it be realistic to disable this on windows7 as well?
Sure, just add another 'if' line to the "disabled:" block:

  if os == "win" and version == (whatever the win 7 version string is): https://bugzilla.mozilla.org/show_bug.cgi?id=1387923
Flags: needinfo?(james)

Comment 24

a year ago
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/426b9dd6bd3b
disable hr-time/timeOrigin.html on windows7. r=me a=testonly
and added a skip for win7, this should be little to no failures now.
Keywords: leave-open
Whiteboard: [stockwell needswork] → [stockwell disabled]
44 failures in 143 pushes (0.308 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 25
* mozilla-inbound: 13
* try: 5
* oak: 1

Platform breakdown:
* windows7-32: 32
* windows10-64: 8
* osx-10-10: 2
* windows7-32-stylo: 1
* macosx64-stylo: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-22&endday=2017-08-22&tree=all
116 failures in 908 pushes (0.128 failures/push) were associated with this bug in the last 7 days. 

This is the #10 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 65
* mozilla-inbound: 29
* mozilla-central: 11
* try: 10
* oak: 1

Platform breakdown:
* windows7-32: 77
* windows10-64: 22
* osx-10-10: 7
* windows10-64-stylo: 6
* windows7-32-stylo: 2
* macosx64-stylo: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-21&endday=2017-08-27&tree=all
22 failures in the last 7 days on osx and win10:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923

I think there is work to get the hr-time tests more reliable, no need to look deeper into this yet.
See Also: → bug 1394685
11 failures in 939 pushes (0.012 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 6
* mozilla-inbound: 4
* mozilla-central: 1

Platform breakdown:
* osx-10-10: 6
* macosx64-stylo: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-08-28&endday=2017-09-03&tree=all
9 failures in 924 pushes (0.01 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 5
* mozilla-central: 3
* mozilla-inbound: 1

Platform breakdown:
* macosx64-stylo-disabled: 5
* osx-10-10: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-09-04&endday=2017-09-10&tree=all
5 failures in 1032 pushes (0.005 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 3
* mozilla-inbound: 2

Platform breakdown:
* osx-10-10: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1387923&startday=2017-09-11&endday=2017-09-17&tree=all
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WORKSFORME
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.