Closed Bug 1387993 Opened 2 years ago Closed 2 years ago

Enable Stylo chrome mochitests on linux debug build

Categories

(Core :: CSS Parsing and Computation, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: xidorn, Assigned: xidorn)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Stylo])

Attachments

(1 file)

In bug 1383992, they are currently marked as tier-3 and run on try only, because they fail consistently due to bug 1384701.

After that bug gets fixed, we should be able to enable those tests as tier-2 or tier-1.
Priority: -- → P2
Depends on: 1383992
(Changing bug summary and whiteboard to match :bholley's new scheme for infrastructure bugs like this.)
Summary: stylo: Enable chrome and clipboard mochitests on linux64 debug build → Enable Stylo chrome and clipboard mochitests on linux64 debug build
Whiteboard: [Stylo]
Summary: Enable Stylo chrome and clipboard mochitests on linux64 debug build → Enable Stylo chrome, clipboard, browser-chrome, and a11y mochitests on linux64 debug build
32-bit is also affected.
Summary: Enable Stylo chrome, clipboard, browser-chrome, and a11y mochitests on linux64 debug build → Enable Stylo chrome, clipboard, browser-chrome, and a11y mochitests on linux debug build
browser-chrome appears unaffected, I filed bug 1393819 to enable it for linux64-stylo/debug (32-bit was already on and working).
Summary: Enable Stylo chrome, clipboard, browser-chrome, and a11y mochitests on linux debug build → Enable Stylo chrome, clipboard, and a11y mochitests on linux debug build
Yep, it looks like all tests are no longer affected.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=183bca8aff06dc698683c94cdea36489e21c40a5

Still need to figure out the failures and mark them correctly to enable them, though.
No longer depends on: 1384701
Oh, well, there is still one task affected. mochitest-chrome-1 on linux64.

My guess is that, the issue of bug 1384701 isn't really fixed, but with some recent changes (e.g. bug 1383332, bug 1393632), it becomes unlikely to hit in test documents (because they are small, and don't change a lot).
Since clipboard and a11y appear to be working now, let's enable them to avoid regressions.

I filed bug 1394887 to do that.  We can leave this for mochitest chrome, which appears to still be blocked on the Cairo assertion.

In the Stylo meeting, we discussed how to proceed here to unblock flipping the default to Stylo.  For now, we will wait for :karlt's investigation.
Depends on: 1384701
Summary: Enable Stylo chrome, clipboard, and a11y mochitests on linux debug build → Enable Stylo chrome mochitests on linux debug build
Assignee: nobody → xidorn+moz
I think it's reasonable to disable layout/style/test/chrome/test_stylesheet_clone_import_rule.html for now if needed (bug 1378577) so we can move forward here and unblock flipping to Stylo.
I agree. I just need a bug to annotate on the skip-if, and I was not sure whether I should reopen the original bug for it, or open a new bug.
(In reply to Xidorn Quan [:xidorn] UTC+10 from comment #9)
> I agree. I just need a bug to annotate on the skip-if, and I was not sure
> whether I should reopen the original bug for it, or open a new bug.

Ah, a new bug 1395322 was filed, so that seems like the right one to mention.
No longer depends on: 1384701
Comment on attachment 8902964 [details]
Bug 1387993 - Enable chrome mochitests on linux debug build.

https://reviewboard.mozilla.org/r/174738/#review179790

yay!
Attachment #8902964 - Flags: review?(jmaher) → review+
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a039adf49a18
Enable chrome mochitests on linux debug build. r=jmaher
https://hg.mozilla.org/mozilla-central/rev/a039adf49a18
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.