tab strip does not scroll continuously when holding down left/right scroll buttons

RESOLVED DUPLICATE of bug 1387130

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1387130
4 months ago
3 months ago

People

(Reporter: heycam, Unassigned)

Tracking

({regression})

52 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
STR:

1. Have enough tabs that the left/right chevron scroll buttons are displayed.
2. Click and hold on one of the buttons.

Actual results:

The tab strip scrolls in steps, one tab at a time.

Expected results:

The tab strip scroll continuously.


10:36.94 INFO: Last good revision: db88d543de14b78333b095485de56cb8e9832af9
10:36.94 INFO: First bad revision: e1c23455946bd42445a0a12d223c7548c39c9785
10:36.94 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=db88d543de14b78333b095485de56cb8e9832af9&tochange=e1c23455946bd42445a0a12d223c7548c39c9785

It's probably bug 1356705.

Updated

4 months ago
Duplicate of this bug: 1387763

Comment 2

4 months ago
More information from  https://bugzilla.mozilla.org/show_bug.cgi?id=1387763 (resolved dup of this)

57.0a1 (2017-08-06) (32-bit) continues the jerky slow behaviour with < or > tab-bar scrolling

Using mouse-wheel to scroll tabs remains acceptable smooth scroll. 

[ Keyboard arrows have no effect when tab is selected. I'm unsure of design spec. ] 


+ Sometimes if I hold the "<", the tabs will move, but when I release the "<", they jump a further few places

Playing around, I did note that using < or > can cause quite erratic jumps, worse under conditions of load = many browser windows & many tabs (+ maybe youtubes as well). 
Running under win10, on an oldish laptop dell Latitude D520 (adequate, 4GB, Core2 CPU T5600 @ 1.83GHz
Works ok if I am cautious & caeful). I suspect less of a problem for more capable rigs.

+ I think there was a config item at one time to smooth-scroll tab-bar (which still happens if I use mousewheel); I wonder if that is/was relevant.

+ Noted also, possibly irrelevant clue: horizontal scrolling inside a large rendered webpage seems to have similar behaviour, moves in jumps.

Updated

4 months ago
No longer blocks: 1356705
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1387130
You need to log in before you can comment on or make changes to this bug.