[DataLoss] Eliminate SchemaTable

RESOLVED FIXED

Status

()

Firefox for iOS
Data Storage
P1
normal
RESOLVED FIXED
9 months ago
8 months ago

People

(Reporter: justindarc, Assigned: justindarc)

Tracking

unspecified
Other
iOS
Dependency tree / graph

Firefox Tracking Flags

(fxios9.0)

Details

(Whiteboard: [MobileCore][DataLoss])

Attachments

(1 attachment)

(Assignee)

Description

9 months ago
The `tableList` table (otherwise known as `SchemaTable`) is a source of major pain while trying to improve our DB init code. It needs to go.
(Assignee)

Updated

9 months ago
Assignee: nobody → jdarcangelo
Status: NEW → ASSIGNED
Iteration: --- → 1.26
tracking-fxios: --- → 8.2
Priority: -- → P1
Whiteboard: [MobileCore][DataLoss]
(Assignee)

Updated

9 months ago
Iteration: 1.26 → 1.27
Duplicate of this bug: 1382732

Updated

8 months ago
tracking-fxios: 8.2 → 8.3
(Assignee)

Comment 2

8 months ago
Created attachment 8896474 [details] [review]
GitHub Pull Request

Preliminary WIP
Attachment #8896474 - Flags: feedback?(rnewman)

Updated

8 months ago
Iteration: 1.27 → 1.28
(Assignee)

Updated

8 months ago
tracking-fxios: 8.3 → 9.0
(Assignee)

Comment 3

8 months ago
Comment on attachment 8896474 [details] [review]
GitHub Pull Request

Alright man... I think this MegaPatch™ is ready for review. Apologies in advance for the size of this PR. I owe you beers at next work week :-)
Attachment #8896474 - Flags: feedback?(rnewman) → review?(rnewman)
(Assignee)

Updated

8 months ago
Blocks: 1368719
(Assignee)

Comment 4

8 months ago
Landed on master:

https://github.com/mozilla-mobile/firefox-ios/commit/1330e4e966c3c9d160c554d79f1e2db881ee2d55

Needs uplifted to v9.x
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
Whiteboard: [MobileCore][DataLoss] → [MobileCore][DataLoss][needsuplift]
(Assignee)

Comment 5

8 months ago
Comment on attachment 8896474 [details] [review]
GitHub Pull Request

Carrying over R+ from GitHub.
Attachment #8896474 - Flags: review?(rnewman) → review+
(Assignee)

Comment 6

8 months ago
Landed on v9.x:

https://github.com/mozilla-mobile/firefox-ios/commit/81375eeb7f19704ca4282ae888a9245bbb3c5aa2
Whiteboard: [MobileCore][DataLoss][needsuplift] → [MobileCore][DataLoss]
(Assignee)

Updated

8 months ago
Blocks: 1394185
You need to log in before you can comment on or make changes to this bug.