Closed Bug 1394185 Opened 2 years ago Closed 2 years ago

SQL error or missing database no such table: tabs

Categories

(Firefox for iOS :: Data Storage, defect, P1)

Other
iOS
defect

Tracking

()

RESOLVED FIXED
Iteration:
1.29
Tracking Status
fxios 9.0 ---

People

(Reporter: justindarc, Assigned: justindarc)

References

Details

(Whiteboard: [MobileCore][DataLoss])

Attachments

(1 file)

55 bytes, text/x-github-pull-request
justindarc
: review+
Details | Review
In the latest Firefox for iOS v9.0 Beta (5571), we're seeing the following error report in Sentry:

SQL error. Error code: 1, Error Domain=org.mozilla Code=1 "SQL error or missing database no such table: tabs" UserInfo={NSLocalizedDescription=SQL error or missing database no such table: tabs} for SQL CharacterView(_core: Swift._StringCore(_baseAddress: Optional(0x00000001c44a8600), _countAndFlags: 39, _owner: Optional(Swift.ManagedBuffer<Swift._HeapBufferHeader<Swift._StringBufferIVars>, Swift.UInt16>)), _coreOffset: 0).

This may be related to Bug 1388147 since `tabs` was one of the tables that was previously managed by the schema table.
Marking as P1 9.0 blocker and assigning to myself.
Assignee: nobody → jdarcangelo
Status: NEW → ASSIGNED
Iteration: --- → 1.29
Depends on: 1388147
Priority: -- → P1
Whiteboard: [MobileCore][DataLoss]
Depends on: 1394186
I thought we were seeing this earlier, too. My hypothesis then was that DB recovery in one process was blowing away the open DB, which will induce errors like this in the other process.
Attached file GitHub Pull Request
Attachment #8902427 - Flags: review?(rnewman)
Comment on attachment 8902427 [details] [review]
GitHub Pull Request

Carrying over R+ from GitHub
Attachment #8902427 - Flags: review?(rnewman) → review+
Duplicate of this bug: 1368719
You need to log in before you can comment on or make changes to this bug.