If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Update harfbuzz to version 1.4.8

RESOLVED FIXED in Firefox 57

Status

()

Core
Graphics: Text
RESOLVED FIXED
a month ago
27 days ago

People

(Reporter: RyanVM, Assigned: RyanVM)

Tracking

Trunk
mozilla57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a month ago
+++ This bug was initially created as a clone of Bug #1382083 +++

Overview of changes leading to 1.4.8
 * Major fix to avar table handling.
 * Rename hb-shape --show-message to --trace.
 * Build fixes.

The avar issues in question go back to version 1.4.2 AFAICT. Not sure what the severity is and whether we need to consider backports for them or not.
No, 'avar' relates to variation fonts, which we don't yet support (except behind a pref, on macos only, and we don't have all the harfbuzz stuff hooked up anyway). So no need to backport for that.
(Assignee)

Comment 2

a month ago
Created attachment 8895136 [details] [diff] [review]
update harfbuzz to version 1.4.8

https://treeherder.mozilla.org/#/jobs?repo=try&revision=9c16b795ed7a10f0fc4c08968b07f3ee359624c9
Attachment #8895136 - Flags: review?(jfkthame)
Comment on attachment 8895136 [details] [diff] [review]
update harfbuzz to version 1.4.8

Review of attachment 8895136 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8895136 - Flags: review?(jfkthame) → review+

Comment 4

a month ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4300642a6667
Update harfbuzz to version 1.4.8. r=jfkthame
(Assignee)

Comment 5

a month ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4300642a6667
Status: NEW → RESOLVED
Last Resolved: a month ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Duplicate of this bug: 1388957

Updated

27 days ago
Blocks: 1393375
You need to log in before you can comment on or make changes to this bug.