The "about:addons" section has not been updated for Photon UI

VERIFIED FIXED in Firefox 57

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: u597134, Assigned: ntim)

Tracking

(Depends on 1 bug, {nightly-community})

57 Branch
mozilla57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 verified)

Details

(Whiteboard: [photon-preference])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Posted image Screenshot.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170809100326

Steps to reproduce:

Opened "about:addons" by clicking the "Add-ons" section in the Firefox menu.


Actual results:

I saw the Australis theme for the "about:addons" with black text for the left panel.


Expected results:

I should have seen the Photon UI look for "about:addons".
(Reporter)

Updated

2 years ago

Updated

2 years ago
Blocks: 1361957
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [photon-structure]
This should be part of photon-preference. We need to consistently make design changes in common.inc.css rather than just preferences.css.
Whiteboard: [photon-structure] → [photon-preference][triage]
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Blocks: 1377167
(Assignee)

Updated

2 years ago
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED

Comment 2

2 years ago
Checking all links in about:about only a handful show side tabs; of these only about:preferences got the full new look while the others are affected by a dark tab background with black (darker?) letters, at least:

* about:addons
* about:debugging
* about:networking
* about:telemetry
Blocks: 1388821
Comment hidden (mozreview-request)

Comment 4

2 years ago
mozreview-review
Comment on attachment 8895510 [details]
Bug 1388761 - Update category styling in common.css.

https://reviewboard.mozilla.org/r/166710/#review171874

Thanks Tim!
Attachment #8895510 - Flags: review?(dao+bmo) → review+
Component: Add-ons Manager → Themes

Comment 5

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/54375b69ac4a
Update category styling in common.css. r=dao
Whiteboard: [photon-preference][triage] → [photon-preference]
Hi Tim,

According to the updated preferences photon visual spec[1], the `--in-content-page-background` color should be `#F9F9Fa` not `#fafafc`. The spec is just updated. I will update the background color at Bug 1389002.

Thank you for updating the preferences's css.

[1]: https://mozilla.invisionapp.com/share/X8BGCX9PD#/screens/244683005
Blocks: 1389002
And I think we might also need to update the background color of `#categories` selector. I'll also update it at Bug 1389002.

[1]: http://searchfox.org/mozilla-central/source/toolkit/themes/shared/in-content/common.inc.css#640
No longer blocks: 1389136
Duplicate of this bug: 1389136
No longer blocks: 1388821
Duplicate of this bug: 1388821

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/54375b69ac4a
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Depends on: 1389179

Updated

2 years ago
Duplicate of this bug: 1389446

Updated

2 years ago
Depends on: 1391325
I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 57.0a1 (2017-08-11), so I'm marking this bug as VERIFIED. Thanks.
Status: RESOLVED → VERIFIED
QA Contact: Virtual
Priority: -- → P1
You need to log in before you can comment on or make changes to this bug.