Closed Bug 1389412 Opened 3 years ago Closed 3 years ago

Data loss: Sometimes (version upgrades?) I lose most but not all (recent tabs come back) of my session history

Categories

(Firefox for Android :: General, defect)

55 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1379374

People

(Reporter: trs80, Unassigned)

Details

User Agent: Mozilla/5.0 (Android 7.0; Mobile; rv:55.0) Gecko/55.0 Firefox/55.0
Build ID: 20170803202939

Steps to reproduce:

Launch Firefox, after upgrading it yesterday. After the upgrade all my tabs were there


Actual results:

I only had 13 tabs instead of the expected >100. This did include a private tab


Expected results:

All my tabs should have been restored. This is the second time this has happened, I don't know if it was around an upgrade last time, but it's possible.
> This did include a private tab

Do you mean that
- one of the > 100 tabs that got lost was a private tab, or
- one of the 13 tabs that survived was a private tab?

Also, how many private tabs did you have open beforehand? Just the one?

Was there some pattern to the tabs that survived, i.e. was it
- the first n tabs,
- or the last n tabs,
- or n contiguous tabs from the middle,
- or some random selection of n tabs (but possibly still in the correct relative order)?

Or were these 13 tabs by any chance the tabs you had touched during the last browsing session?

On the off chance that this happens again, could you please turn on full logging by enabling "consoleservice.logcat" and "browser.sessionstore.debug_logging" in about:config (needs a restart to become effective) and then get a log as soon as you encounter this again?

You can either connect your phone to a computer and use ADB (https://developer.android.com/studio/releases/platform-tools.html, https://developer.android.com/studio/command-line/adb.html#Enabling) with the following command line:

Windows
> adb logcat -dv threadtime | findstr Gecko > log.txt

Linux/Mac
> adb logcat -dv threadtime | grep Gecko > log.txt

or you can try installing the Log View add-on (https://addons.mozilla.org/android/addon/logview/) and then attempt using that to get a log if this behaviour happens again.
Flags: needinfo?(trs80)
(In reply to Jan Henning [:JanH] from comment #1)
> Or were these 13 tabs by any chance the tabs you had touched during the last
> browsing session?

Or perhaps even tabs that were actually opened just during the last browsing session?
Hi Jan,

(In reply to Jan Henning [:JanH] from comment #1)
> > This did include a private tab
> 
> Do you mean that
> - one of the > 100 tabs that got lost was a private tab, or
> - one of the 13 tabs that survived was a private tab?
> 
> Also, how many private tabs did you have open beforehand? Just the one?

13 regular tabs and one private tab survived. I'm not sure if there were any private tabs that were lost, I don't think so.

> Was there some pattern to the tabs that survived, i.e. was it
> - the first n tabs,
> - or the last n tabs,
> - or n contiguous tabs from the middle,
> - or some random selection of n tabs (but possibly still in the correct
> relative order)?
> 
> Or were these 13 tabs by any chance the tabs you had touched during the last
> browsing session?
>
> Or perhaps even tabs that were actually opened just during the last browsing
> session?

I'm pretty sure they were the last n tabs, both times, so perhaps it was the ones that were opened during the last session. I had definitely touched some non-contiguous older tabs in the last day, although I stick to the last 10-15 tabs normally.

> On the off chance that this happens again, could you please turn on full
> logging by enabling "consoleservice.logcat" and
> "browser.sessionstore.debug_logging" in about:config (needs a restart to
> become effective) and then get a log as soon as you encounter this again?

OK, I've enabled those and will keep an eye out.

> You can either connect your phone to a computer and use ADB
> (https://developer.android.com/studio/releases/platform-tools.html,
> https://developer.android.com/studio/command-line/adb.html#Enabling) with
> the following command line:
> 
> Windows
> > adb logcat -dv threadtime | findstr Gecko > log.txt
> 
> Linux/Mac
> > adb logcat -dv threadtime | grep Gecko > log.txt
> 
> or you can try installing the Log View add-on
> (https://addons.mozilla.org/android/addon/logview/) and then attempt using
> that to get a log if this behaviour happens again.

I've installed the Log View addon and will try to get the adb logcat too if I'm around a computer at the time.

Do you want to leave this in NEEDINFO until I can get some logs?

Thanks for the debugging info.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(trs80)
Resolution: --- → DUPLICATE
Duplicate of bug: 1379374
You need to log in before you can comment on or make changes to this bug.