Closed Bug 1389559 Opened 2 years ago Closed 2 years ago

Add-ons pane now is extra-wide and has a scrollbar for half-screen-width window sizes, due to "Missing something? Some extensions are no longer supported by Nightly. [Show legacy extensions]" blurb

Categories

(Toolkit :: Add-ons Manager, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: dholbert, Assigned: mstriemer)

References

Details

(Keywords: regression)

Attachments

(6 files)

STR:
 1. Visit about:addons and click "Extensions"
 2. Make your window ~900px wide.  (Or may

ACTUAL RESULTS:

The viewport for the addons area is too wide. (The long "Missing something? Some extensions are no longer supported" message imposes a minimum width)

This manifests as follows:
 - Horizontal scrollbar
 - The "search" field is positioned arbitrarily too var to the right, so it overflows the visible area and its "magnifying glass" icon isn't visible.
 - If you have extensions installed, their "Remove" buttons are positioned too far to the right and are clipped as well.

EXPECTED RESULTS:
The "Missing something? Some extensions are no longer supported" message should allow itself to wrap to multiple lines, to gracefully handle smaller windows.


This bug fixes itself if I delete the "Missing something" node using devtools -- so it's definitely a problem with that node.
Attachment #8896369 - Attachment description: screenshot of issue → screenshot of issue, with 960px-wide window
Attachment #8896370 - Attachment description: screenshot of expected rendering before regression (note searchbox & absence of scrollbar) → screenshot of expected rendering before regression, with 960px-wide window (note searchbox & absence of scrollbar)
Here's another screenshot, before the regression, with a much smaller window (514px wide).

The add-ons pane was still admirably responsive at this size, which was great! (some text was ellipsized/wrapped, but nothing overflows, and the search box was still 100% visible)

But with this regression, the searchbox isn't even visible in a window of this size, because this super-wide warning message pushes it wayyy off to the right, by virtue of creating a large scrollable area.
Most proximally, this was a regression from bug 1388946 (which just landed in today's Nightly) -- though that was just a pref-flip, so really it's a regression from a change that happened longer ago & was just masked by the pref being disabled.

Probably really a regression from bug 1360777, since some brief searchfox archeology indicates that that's where we added this UI...?
Blocks: 1388946, 1360777
Flags: needinfo?(aswan)
Keywords: regression
(In reply to Daniel Holbert [:dholbert] from comment #4)
> Probably really a regression from bug 1360777

Confirmed, this was a regression from bug 1360777 (using mozregression with a Firefox profile that has the legacy-addons pref forcibly set to "false").
I just noticed that the "Experiments" pane (on about:addons) has the same problem -- it's got a similarly-long message which acts as a "strut" to force the viewport to be at least a certain width.

(In this case the message is "What's this? Telemetry may install and run experiments from time to time. [Learn More][Telemetry Settings]")

As with the Extensions pane: the problem goes away if I delete this message using DevTools.
Summary: Add-ons pane now is extra-wide and has a scrollbar for reasonable window sizes, due to "Missing something? Some extensions are no longer supported by Nightly. [Show legacy extensions]" blurb → Add-ons pane now is extra-wide and has a scrollbar for half-screen-width window sizes, due to "Missing something? Some extensions are no longer supported by Nightly. [Show legacy extensions]" blurb
There's a similar header on the Plugins pane too.
Redirect to Mark, I suspect there's some simple style that can be applied to make that text wrap.
Flags: needinfo?(aswan) → needinfo?(mstriemer)
Priority: -- → P2
Assignee: nobody → mstriemer
Flags: needinfo?(mstriemer)
Comment on attachment 8902926 [details]
Bug 1389559 - Wrap about:addons warnings to maintain narrow layouts

https://reviewboard.mozilla.org/r/174654/#review179780
Attachment #8902926 - Flags: review?(rhelmer) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d2ad47692c87
Wrap about:addons warnings to maintain narrow layouts r=rhelmer
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d2ad47692c87
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.