Closed Bug 1389573 Opened 3 years ago Closed 1 year ago

Align one-off buttons to the Address Bar input field

Categories

(Firefox :: Address Bar, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1561894
Tracking Status
firefox57 --- wontfix

People

(Reporter: soeren.hentzschel, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxsearch])

Attachments

(3 files)

Attached image wasted-space.png
I really like the empty space aka "flexible space" on the left side and on the right side of the address bar. But in my opinion it does not make sense in the awesome bar popup at all.

If I remove the left flexible space the awesomebar popup does look *much better* but I don't want to remove it!

Please let me use the full width for the aweseomebar popup while keeping the flexible spaces in the toolbar. For me it's a big visual regression. It is *a lot* of wasted space.

Another problem is that the search engine icons don't have the same empty space on the left side. Both should start at the same position. It does not look intended, it looks like an error.
Stephen/Bryan, opinions?
Blocks: 1383009
Flags: needinfo?(shorlander)
Flags: needinfo?(bbell)
Summary: photon regression: empty space in awesomebar popup should not depend on flexible toolbar spaces → Should be stricter about aligning items in the awesomebar popup with the location bar (do more to avoid empty space to the left of results in awesomebar popup)
Attaching a spec for fixing the alignment issues on the awesomebar footer.
Flags: needinfo?(shorlander)
Flags: needinfo?(bbell)
This spec solves only one part of the problem, not the main point of this ticket.
Component: Theme → Address Bar
(In reply to Sören Hentzschel from comment #3)
> This spec solves only one part of the problem, not the main point of this
> ticket.

If the main point is that we should remove the alignment on the left, that's a wontfix, it was deliberate UX decision to align results on the input field. I think you can override that through userChrome.css.
I don't know what's the priority of aligning the one-off buttons, adding to triage, it looks low priority, but UX may think differently.
Whiteboard: [fxsearch]
Summary: Should be stricter about aligning items in the awesomebar popup with the location bar (do more to avoid empty space to the left of results in awesomebar popup) → Align one-off buttons to the Address Bar input field
Attached image ab-alignment.png
Adding Eric here who is doing most of the design work on the Awesomebar these days. We can move the one-off buttons to align with the search results. In that case we should make the first icon align with the icons in the list.
The settings icon looks quite lonely when aligned with the end of the bar, so let's keep that where it is right now.
Priority: -- → P2

There is a new design by Verdi that is being worked on in bug 1561894, so this is obsolete.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1561894
You need to log in before you can comment on or make changes to this bug.