New Tab button should move 2px to the left

VERIFIED FIXED in Firefox 57

Status

()

Firefox
Theme
P1
normal
VERIFIED FIXED
9 months ago
9 months ago

People

(Reporter: Virtual, Assigned: dao)

Tracking

(Blocks: 1 bug, {nightly-community, ux-consistency})

57 Branch
Firefox 57
x86_64
Windows 7
nightly-community, ux-consistency
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 verified)

Details

(Whiteboard: [reserve-photon-visual])

MozReview Requests

()

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(7 attachments)

STR:
1. Hover over "Open a new tab" button in tab bar
and see that it need some tuning to be like on Photon specification - http://design.firefox.com/people/shorlander/photon/Mockups/windows-7.html


Some data

"Open a new tab" button size:
36 x 26 px - before landing patch from bug #1377184
28 x 28 px - after landing patch from bug #1377184
28 x 28 px - in Photon specification

"Open a new tab" button active hover area:
36 x 26 px - before landing patch from bug #1377184
36 x 26 px - after landing patch from bug #1377184
28 x 28 px - in Photon specification

Space between Tab and "Open a new tab" button:
4 px - after landing patch from bug #1377184
2 px - in Photon specification


So in tl;dr "Open a new tab" button:
- should be moved 2 px to the left
- active hover area should be only on the button area


Regression range pushlog:
https://hg.mozilla.org/integration/autoland/json-pushes?changeset=500a01cf896dbb9883cb85f162552e20b8facfc0&full=1

Caused by:
Bug 1377184 - Use new Photon hover effect also on "Show more bookmarks" and extensions buttons icons in Bookmarks Toolbar
Blocks: 1377184
Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: regression → ux-consistency

Comment 7

9 months ago
One more thing. Looks like the "Open a new tab" button has slightly different parameters for every UI density option. For example there is only 1 px gap between Tab and Open a new tab button in Compact mode.
I forgot to mention, that my screenshots are with Compact density mode.

Comment 9

9 months ago
As far as I can see all your screenshots are from Normal density mode. Check the density options on the Mockup page. There is a difference in Back button design.
(Assignee)

Comment 11

9 months ago
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #0)
> So in tl;dr "Open a new tab" button:
> - should be moved 2 px to the left
> - active hover area should be only on the button area

We don't have plans to do the latter. Morphing bug.
Summary: Tune "Open a new tab" button → New Tab button should move 2px to the left
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual]

Updated

9 months ago
Flags: qe-verify?
Priority: -- → P4
Duplicate of this bug: 1389800
(Assignee)

Updated

9 months ago
Priority: P4 → P3
(Assignee)

Updated

9 months ago
Assignee: nobody → dao+bmo
Flags: qe-verify? → qe-verify+
Priority: P3 → P1
Comment hidden (mozreview-request)

Updated

9 months ago
Status: NEW → ASSIGNED
Iteration: --- → 57.2 - Aug 29

Comment 14

9 months ago
mozreview-review
Comment on attachment 8898661 [details]
Bug 1389921 - Stop setting a width on the new tab button to remove excess padding around it.

https://reviewboard.mozilla.org/r/170042/#review175932

Looks good cheers
Attachment #8898661 - Flags: review?(dharvey) → review+

Comment 15

9 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cc018eee995b
Stop setting a width on the new tab button to remove excess padding around it. r=daleharvey

Comment 16

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cc018eee995b
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Just for the record, this caused some conflicts when I merged bug 1352119 to m-c from inbound. I think I resolved it correctly, though.
Flags: needinfo?(dao+bmo)
(Assignee)

Comment 18

9 months ago
(In reply to Wes Kocher (:KWierso) from comment #17)
> Just for the record, this caused some conflicts when I merged bug 1352119 to
> m-c from inbound. I think I resolved it correctly, though.

Looks like it.
Flags: needinfo?(dao+bmo)
(Assignee)

Updated

9 months ago
Blocks: 1390328
I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 57.0a1 (2017-08-22), so I'm marking this bug as VERIFIED. Thanks.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified

Updated

9 months ago
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.