Closed Bug 1390200 Opened 2 years ago Closed 2 years ago

Disable NSUserActivity/CoreSpotlight temporarily

Categories

(Firefox for iOS :: General, enhancement, P1)

Other
iOS
enhancement

Tracking

()

RESOLVED FIXED
Iteration:
1.27
Tracking Status
fxios 8.2 ---

People

(Reporter: justindarc, Assigned: justindarc)

References

(Blocks 1 open bug)

Details

(Whiteboard: [MobileCore])

Attachments

(1 file)

55 bytes, text/x-github-pull-request
justindarc
: review+
Details | Review
We are unsure if this is the cause of:

fatalApplication threw exception NSGenericException: *** Collection <__NSDictionaryM: 0x1c062faa0> was mutated while being enumerated.

But, these attributes *may* be nil:

https://github.com/mozilla-mobile/firefox-ios/blob/master/Client/Helpers/SpotlightHelper.swift#L79
Assignee: nobody → jdarcangelo
Status: NEW → ASSIGNED
Iteration: --- → 1.27
Priority: -- → P1
Whiteboard: [MobileCore]
We're seeing some random crashes around NSUserActivity and CoreSpotlight, including the one in Comment #0. Its clear that the helper code is fragile so let's just disable this functionality for the time being until a better implementation can be completed.
Summary: Ensure Spotlight attributes are not nil → Disable NSUserActivity/CoreSpotlight temporarily
Attached file GitHub Pull Request
Attachment #8897131 - Flags: review?(sarentz)
Blocks: 1390293
Blocks: 1390294
This did not build on BuddyBuild because we disabled building of PRs from external repositories. But I ran build & test locally and that was all green for me, so ..

Landed on master, uplifted to v8.x
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Comment on attachment 8897131 [details] [review]
GitHub Pull Request

Carrying over R+ from GitHub.
Attachment #8897131 - Flags: review?(sarentz) → review+
You need to log in before you can comment on or make changes to this bug.