Closed Bug 1390433 Opened 2 years ago Closed 2 years ago

Uplift Form Autofill system add-on for 56 beta

Categories

(Toolkit :: Form Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla57
Tracking Status
thunderbird_esr52 --- unaffected
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 + verified
firefox57 --- verified

People

(Reporter: vchen, Assigned: steveck)

References

Details

(Keywords: qawanted, Whiteboard: [SHERIFFS: MattN will uplift] [go-faster-system-addon] [form autofill:MVP])

Attachments

(1 file, 38 obsolete files)

59 bytes, text/x-review-board-request
MattN
: review+
Details
(This is the wrong Product/Component maybe...)

This bug exists to track the uplift of Form Autofill to 56 beta and the staged rollout. 

Wiki : https://wiki.mozilla.org/Firefox/Features/Form_Autofill
Code : https://dxr.mozilla.org/mozilla-central/source/browser/extensions/formautofill/
Whiteboard: [go-faster-system-addon] → [go-faster-system-addon] [form autofill:MVP]
The summary was confusing some people.
Summary: Land Form Autofill as a system add-on for 56 beta → Uplift Form Autofill system add-on for 56 beta
Attachment #8898683 - Flags: review?(MattN+bmo)
Attachment #8898684 - Flags: review?(schung)
Attachment #8898685 - Flags: review?(lchang) → review?(MattN+bmo)
Attachment #8898686 - Flags: review?(schung) → review?(MattN+bmo)
Attachment #8898688 - Flags: review?(selee)
Attachment #8898688 - Flags: review?(schung)
Attachment #8898688 - Flags: review?(MattN+bmo)
Attachment #8898689 - Flags: review?(selee) → review?(MattN+bmo)
Attachment #8898690 - Flags: review?(rhelmer) → review?(MattN+bmo)
Attachment #8898692 - Flags: review?(lchang) → review?(MattN+bmo)
Attachment #8898693 - Flags: review?(selee)
Attachment #8898694 - Flags: review?(selee)
Attachment #8898696 - Flags: review?(selee)
Attachment #8898696 - Flags: review?(lchang)
Attachment #8898696 - Flags: review?(MattN+bmo)
Attachment #8898699 - Flags: review?(lchang) → review?(MattN+bmo)
We have a packaging problem on the try push:

Linux x64 opt Executed by TaskCluster build-linux64/opt tc(B):
> Error: Locale doesn't have a manifest entry for 'formautofill'
Comment on attachment 8898662 [details]
Bug 1390433 - Uplift Form Autofill system add-on for 56 beta.

https://reviewboard.mozilla.org/r/170054/#review175370

::: browser/extensions/moz.build:12
(Diff revision 3)
>      'followonsearch',
> +    'formautofill',
>      'onboarding',

When this move to mozilla-release it will be enabled for all en-US US users on day 1. If we're still doing a gradual rollout as a system add-on then we should probably either change the moz.build or `startup` in bootstrap.js to not run if we're on the release channel.

Maybe:
```python
# formautofill will be rolled out via balrog in release
if CONFIG['MOZ_UPDATE_CHANNEL'] != 'release':
```
Attachment #8898662 - Flags: review?(MattN+bmo)
Comment on attachment 8898662 [details]
Bug 1390433 - Uplift Form Autofill system add-on for 56 beta.

Approval Request Comment
[Feature/Bug causing the regression]: https://wiki.mozilla.org/Firefox/Features/Form_Autofill
[User impact if declined]: No autofill for en-US users in the US
[Is this code covered by automated tests?]: yes, both bc and xpcshell
[Has the fix been verified in Nightly?]: yes, it got pre-beta signoff
[Needs manual test from QE? If yes, steps to reproduce]: Yes, QA will do another pass.
[List of other uplifts needed for the feature/fix]: This will be uplifted with the following changes https://reviewboard-hg.mozilla.org/gecko/log?rev=f5ef86828ee4%3A%3Ab37ae4700658&revcount=40
[Is the change risky?]: Usual risk from a new feature. This feature has been enabled on Nightly for a few cycles now during development.
[Why is the change risky/not risky?]: It's enabling a new feature on beta that needed some more polish before enabling on beta despite QA signoff.
[String changes made/needed]: The feature isn't localized yet since it's only for en-US for now. flod and pike are aware of this. The strings directory is excluded from localization tooling so it won't cause issues.
Attachment #8898662 - Flags: approval-mozilla-beta?
Assignee: nobody → schung
Status: NEW → ASSIGNED
Flags: qe-verify+
Flags: in-testsuite+
Keywords: qawanted
Priority: -- → P1
Vance has pointed Adrian to the try push build to verify.
Whiteboard: [go-faster-system-addon] [form autofill:MVP] → [SHERIFFS: MattN will uplift] [go-faster-system-addon] [form autofill:MVP]
Attachment #8898683 - Attachment is obsolete: true
Attachment #8898683 - Flags: review?(MattN+bmo)
Attachment #8898684 - Attachment is obsolete: true
Attachment #8898684 - Flags: review?(MattN+bmo)
Attachment #8898685 - Attachment is obsolete: true
Attachment #8898685 - Flags: review?(MattN+bmo)
Attachment #8898686 - Attachment is obsolete: true
Attachment #8898686 - Flags: review?(MattN+bmo)
Attachment #8898687 - Attachment is obsolete: true
Attachment #8898687 - Flags: review?(MattN+bmo)
Attachment #8898688 - Attachment is obsolete: true
Attachment #8898688 - Flags: review?(MattN+bmo)
Attachment #8898689 - Attachment is obsolete: true
Attachment #8898689 - Flags: review?(MattN+bmo)
Attachment #8898690 - Attachment is obsolete: true
Attachment #8898690 - Flags: review?(MattN+bmo)
Attachment #8898691 - Attachment is obsolete: true
Attachment #8898691 - Flags: review?(MattN+bmo)
Attachment #8898692 - Attachment is obsolete: true
Attachment #8898692 - Flags: review?(MattN+bmo)
Attachment #8898693 - Attachment is obsolete: true
Attachment #8898693 - Flags: review?(MattN+bmo)
Attachment #8898694 - Attachment is obsolete: true
Attachment #8898694 - Flags: review?(MattN+bmo)
Attachment #8898695 - Attachment is obsolete: true
Attachment #8898695 - Flags: review?(MattN+bmo)
Attachment #8898696 - Attachment is obsolete: true
Attachment #8898696 - Flags: review?(MattN+bmo)
Attachment #8898697 - Attachment is obsolete: true
Attachment #8898697 - Flags: review?(MattN+bmo)
Attachment #8898698 - Attachment is obsolete: true
Attachment #8898698 - Flags: review?(MattN+bmo)
Attachment #8898699 - Attachment is obsolete: true
Attachment #8898699 - Flags: review?(MattN+bmo)
Attachment #8898700 - Attachment is obsolete: true
Attachment #8898700 - Flags: review?(MattN+bmo)
Attachment #8898701 - Attachment is obsolete: true
Attachment #8898701 - Flags: review?(MattN+bmo)
(In reply to Matthew N. [:MattN] (huge backlog; PM if requests are blocking you) from comment #46)
> Vance has pointed Adrian to the try push build to verify.

Adrian has handed over the Autofill efforts to Release Desktop QA Team, so Gabi will handle it from now on. She will do the sanity check by tomorrow EOD (due to workload).
Comment on attachment 8898662 [details]
Bug 1390433 - Uplift Form Autofill system add-on for 56 beta.

https://reviewboard.mozilla.org/r/170054/#review175920

I still think you should rebase this on top of https://reviewboard-hg.mozilla.org/gecko/rev/83bdb145862a so that you get back the proper original commit messages.
Attachment #8898662 - Flags: review?(MattN+bmo) → review+
Comment on attachment 8898662 [details]
Bug 1390433 - Uplift Form Autofill system add-on for 56 beta.

https://reviewboard.mozilla.org/r/170054/#review175924

::: browser/locales/Makefile.in
(Diff revision 6)
> -ifndef RELEASE_OR_BETA
>  	@$(MAKE) -C ../extensions/formautofill/locales AB_CD=$* XPI_NAME=locale-$*
> -endif

Isn't this going to fail when `CONFIG['MOZ_UPDATE_CHANNEL'] != 'release'`?
Comment on attachment 8898662 [details]
Bug 1390433 - Uplift Form Autofill system add-on for 56 beta.

https://reviewboard.mozilla.org/r/170054/#review175972

::: browser/locales/Makefile.in
(Diff revision 6)
> -ifndef RELEASE_OR_BETA
>  	@$(MAKE) -C ../extensions/formautofill/locales AB_CD=$* XPI_NAME=locale-$*
> -endif

So here would be `ifndef RELEASE` ? BTW, are we sure  to ship it only in beta? I heard that Vance might have different thought.
> So here would be `ifndef RELEASE` ? BTW, are we sure  to ship it only in
> beta? I heard that Vance might have different thought.

As far as I know, how to do with release channel are yet to decide. But for Beta we are just going to have Address fill part included in beta. Probably Beta 6 based on the current schedule.
Attachment #8899399 - Attachment is obsolete: true
Attachment #8899400 - Attachment is obsolete: true
Attachment #8899401 - Attachment is obsolete: true
Attachment #8899402 - Attachment is obsolete: true
Attachment #8899403 - Attachment is obsolete: true
Attachment #8899404 - Attachment is obsolete: true
Attachment #8899405 - Attachment is obsolete: true
Attachment #8899406 - Attachment is obsolete: true
Attachment #8899407 - Attachment is obsolete: true
Attachment #8899408 - Attachment is obsolete: true
Attachment #8899409 - Attachment is obsolete: true
Attachment #8899410 - Attachment is obsolete: true
Attachment #8899411 - Attachment is obsolete: true
Attachment #8899412 - Attachment is obsolete: true
Attachment #8899413 - Attachment is obsolete: true
Attachment #8899414 - Attachment is obsolete: true
Attachment #8899415 - Attachment is obsolete: true
Attachment #8899416 - Attachment is obsolete: true
Attachment #8899417 - Attachment is obsolete: true
Track 56+ as this feature will be enabled in Beta56.
Sanity Check Form Autofill feature is done on macOS 10.12 and Ubuntu 16.04 x64 using try build: https://treeherder.mozilla.org/#/jobs?repo=try&revision=04cc6bb1dac3

3 new tickets were logged but none of them blockers, we do recommend that bug 1393001 gets fixed because it has a direct impact on users.
Comment on attachment 8898662 [details]
Bug 1390433 - Uplift Form Autofill system add-on for 56 beta.

Let's uplift this and enable for beta users in beta 6. It sounds like we would like to test it with the beta audience.

This will still need more testing (on beta) and a final go/no-go decision for 56 release, though.
Attachment #8898662 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3d38ebe3179e
Uplift Form Autofill system add-on for 56 beta. r=MattN
https://hg.mozilla.org/mozilla-central/rev/3d38ebe3179e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
See Also: → 1398656
Form Autofill Address was tested on beta 56 and verified in 57.0b14 under Windows 10x64, Ubuntu 14.4 and MacOS 10.12.6.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.