run mochitest-gpu and mochitest-chrome and mochitest-clipboard on windows 10 (hardware)

RESOLVED FIXED in Firefox 57

Status

enhancement
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jmaher, Assigned: jmaher)

Tracking

(Depends on 1 bug)

Trunk
mozilla57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(1 attachment)

we can run these on hardware, not VM in taskcluster- lets do that here.
Summary: run mochitest-gpu and mochitest-webgl on windows 10 → run mochitest-gpu and mochitest-webgl and mochitest-clipboard on windows 10
Blocks: 1397226
No longer blocks: 1326419
Summary: run mochitest-gpu and mochitest-webgl and mochitest-clipboard on windows 10 → run mochitest-gpu and mochitest-chrome and mochitest-clipboard on windows 10 (hardware)
https://treeherder.mozilla.org/#/jobs?repo=try&revision=591aa6d9d1c9619e56de52c2f32f80e9106b9040

^ you can see webgl isn't ready for prime time, so leave that on windows 8 for now.
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #8905481 - Flags: review?(ahalberstadt)
Comment on attachment 8905481 [details] [diff] [review]
run gpu/chrome/clipboard on windows 10, not on windows 8

Review of attachment 8905481 [details] [diff] [review]:
-----------------------------------------------------------------

Lgtm. Please clarify the windows7 changes.

::: taskcluster/ci/test/tests.yml
@@ -675,5 @@
>      max-run-time: 3600
>      e10s: false
>      run-on-projects:
>          by-test-platform:
> -            windows7-32.*: ['try']

Is this going to run windows7-32 on all branches? Is that intentional?
Attachment #8905481 - Flags: review?(ahalberstadt) → review+
yes- we disabled mochitest-chrome and made it tier-2 for win7; there is no documentation in the bug that switched win7-chrome to tier-2/try- I suspect it happened because there were a few failures.  this gets us back to normal status,  Ihave 2 try pushes with a few data points each showing win7 mochitest-chrome passing successfully.

Comment 6

2 years ago
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3a472353456d
run mochitest-gpu and mochitest-chrome and mochitest-clipboard on windows 10. r=ahal
https://hg.mozilla.org/mozilla-central/rev/3a472353456d
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Depends on: 1398115
You need to log in before you can comment on or make changes to this bug.