Closed Bug 1390871 Opened 3 years ago Closed 2 years ago

NSInvalidArgumentException: -[WKContentView menuHelperFindInPage]: unrecognized selector

Categories

(Firefox for iOS :: General, enhancement, P1)

Other
iOS
enhancement

Tracking

()

RESOLVED FIXED
Iteration:
1.29
Tracking Status
fxios 9.0 ---

People

(Reporter: st3fan, Assigned: farhan)

References

Details

(Whiteboard: [Crash][MobileCore])

Attachments

(1 file)

This may be iOS 11 related. I don't think we have seen this on older versions. Also, there is something odd with the menu helper going on because it only shows Find In Page for selected text. Copy/Paste/Lookup are all missing. So that may be related to our menu code.
Priority: -- → P1
Duplicate of this bug: 1393115
Assignee: nobody → fpatel
Iteration: --- → 1.29
Whiteboard: [Crash] → [Crash][MobileCore]
Blocks: 1392749
This appears to be fixed upstream in Webkit. Expectation that this will be fixed by iOS11.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
This does not seem to be fixed in today's iOS 11 beta 10. My patch could be a good temporary fix.
Whiteboard: [Crash][MobileCore] → [Crash][MobileCore][needsuplift]
Comment on attachment 8905322 [details] [review]
PR https://github.com/mozilla-mobile/firefox-ios/pull/3138

Cleaned up the patch, added some documentation. Whoever grabs it first.
Attachment #8905322 - Flags: review?(gkeeley)
Attachment #8905322 - Flags: review?(fpatel)
Attachment #8905322 - Flags: review?(gkeeley)
Attachment #8905322 - Flags: review?(fpatel)
Attachment #8905322 - Flags: review+
Landed on master, uplifted to v9.x
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Whiteboard: [Crash][MobileCore][needsuplift] → [Crash][MobileCore]
You need to log in before you can comment on or make changes to this bug.