Open Bug 1391239 Opened 2 years ago Updated 16 days ago

pressing AltGr-Enter in the search bar should open page in a new tab

Categories

(Firefox :: Search, defect, P2)

57 Branch
Unspecified
All
defect

Tracking

()

REOPENED
Tracking Status
firefox57 --- wontfix

People

(Reporter: cgohier, Unassigned)

References

Details

(Whiteboard: [fxsearch])

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170816100153

Steps to reproduce:

1. Enter URL in address bar, or search terms in search bar.
2. Press AtlGr-Enter


Actual results:

Page is loaded in current tab.


Expected results:

Page is loaded in new tab, the way it works in Windows.
Component: Untriaged → Location Bar
OS: Unspecified → Linux
I'm using the French (Canada) keyboard layout.
The problem is that ALT+GR is interpreted as CTRL+ALT.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389739
Actually, no. AltGr-Enter does not work like CTRL-ALT-Enter on Linux.

ALT-CTRL-ENTER is canonizing and opening in a new tab.
AltGr-ENTER does the same thing as ENTER alone.
(In reply to Claude Gohier from comment #3)
> Actually, no. AltGr-Enter does not work like CTRL-ALT-Enter on Linux.

Yeah no, not on Linux, it does on Windows.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
See Also: → 1389739
Priority: -- → P2
Whiteboard: [fxsearch]
I'd say Linux is doing it right (AltGr shouldn't be interpreted as ctrl or alt or both), and Windows is in the wrong by emulating some pre-PC-AT behaviour by sending a Ctrl+Alt combo instead of anything sensible.  If anything, the inverse of this bug should be opened and this closed as invalid.  Actually, see Bug 900750.
I'd say the AltGr-Enter combo on Linux is useless, since it just does the same thing as only Enter.

The Windows comportment, having AltGr-Enter doing the same thing as Alt-Enter (loading in a new tab) allows to do a one-handed movement, which can also be considered to be an accessibility issue.

The fix for bug 1389739 seems to have fix this bug.

Fixed for the Address bar, but not the Search bar.

Component: Address Bar → Search
Summary: In Linux, pressing AltGr-Enter in address bar or search bar should open page in a new tab. → In Linux, pressing AltGr-Enter in the search bar should open page in a new tab.
No longer blocks: 1425024

Bhopesh Bassi, could you help, please?

Flags: needinfo?(bbassi)
OS: Linux → All
Summary: In Linux, pressing AltGr-Enter in the search bar should open page in a new tab. → pressing AltGr-Enter in the search bar should open page in a new tab

I can help if someone experienced gives me good pointers on how to fix this. Pointers in https://bugzilla.mozilla.org/show_bug.cgi?id=1389739 helped me fix it quickly.

Flags: needinfo?(bbassi)

Drew Willcoxon, could you please point Bhopesh where to fix this?

I assume it should be smth like this (based on bug 1389739):

https://searchfox.org/mozilla-central/rev/40e889be8ff926e32f7567957f4c316f14f6fbef/browser/components/searchbar/SearchbarInput.jsm#1282

To this:

if (
!isMouseEvent &&
event &&
(event.altKey || event.getModifierState("AltGraph"))
) {

I wish we could get it done for FF70 beta.

Flags: needinfo?(adw)

I will take a look at it.

Any progress? Soon the v70 train will depart... :(

Flags: needinfo?(bbassi)

When does v70 train leave? I have been busy at my day job lately. I will work on it soon.

Flags: needinfo?(bbassi)

Hey Drew, Can you share test cases files as well? Thanks

Flags: needinfo?(adw)

For v70 it is too late (first beta released), if only they do not take the fix in beta cycle in.

It looks like this is the only test that checks enter key handling in the search bar: https://searchfox.org/mozilla-central/source/browser/components/search/test/browser/browser_426329.js

Flags: needinfo?(adw)

Bhopesh Bassi, no hope for a fix?

Flags: needinfo?(bbassi)

I am really sorry Eugene. I have been extremely busy at my new job. I will try to finish it by October end.

Again, I sincerely apologize that it is taking so much time.

Flags: needinfo?(bbassi)
You need to log in before you can comment on or make changes to this bug.