Closed Bug 1391333 Opened 7 years ago Closed 7 years ago

Allow full-width customizable UI via web-extensions

Categories

(WebExtensions :: Untriaged, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1215064

People

(Reporter: sfoster, Unassigned)

Details

With the removal of custom toolbars via legacy add-ons, users are left with no way to develop/enable full-width custom browser UI. The sidebar API provides great flexibility for customization, but being a side panel, it is not suited for content that requires a lot of horizontal space. This is particularly problematic for low-vision users who use large fonts. 

Perhaps the sidebar could become dockable to the bottom of the screen? A more responsive layout would open up options for using the existing Web Extensions API that catered to different user needs without adding much/any API surface area.
Component: Toolbars and Customization → WebExtensions: Untriaged
Product: Firefox → Toolkit
Flags: needinfo?(amckay)
A full width browser UI sounds an awful like a tab or window. But this has been requested in other bugs like the toolbar API bug 1215064 and bug 1373504. Will dupe to the toolbar since that's got the best chance of happening.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(amckay)
Resolution: --- → DUPLICATE
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.