Regression caused by bug 1354336: Can’t use the `.panel-section-tabs-button.selected` class

RESOLVED FIXED in Firefox 63

Status

defect
P5
normal
RESOLVED FIXED
2 years ago
9 months ago

People

(Reporter: e7358d9c, Assigned: e7358d9c)

Tracking

(Blocks 1 bug)

55 Branch
mozilla63
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox63 fixed)

Details

(Assignee)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170814072924

Steps to reproduce:

Created an options page with a `<div>` with the `.panel-section-tabs-button.selected` class.


Actual results:

The `<div>` looks like a `<div>` with only the `.panel-section-tabs-button` class.


Expected results:

The `<div>` should look like a `<div>` with the `.panel-section-tabs-button.selected` class.


Additional information:

The reason why this happened has been explained in bug 1354336 comment 43.

Documentation on the `.panel-section-tabs-button.selected` class is available at:
http://design.firefox.com/StyleGuide/#/navigation
(Assignee)

Updated

2 years ago
Blocks: 1354336

Updated

2 years ago
Priority: -- → P5
(Assignee)

Comment 1

a year ago
:ntim is fixing this as part of bug 1421652, so I’m setting it as a dependency on this (is that how this should be done?).
Depends on: 1421652
(Assignee)

Updated

a year ago
Blocks: 1458678
Status: UNCONFIRMED → NEW
No longer depends on: 1421652
Ever confirmed: true
See Also: → 1421652

Updated

11 months ago
Product: Toolkit → WebExtensions
(Assignee)

Comment 2

9 months ago
In the end, I fixed this as part of bug 1371951:
https://hg.mozilla.org/mozilla-central/rev/e57c44d5ec97
Assignee: nobody → e7358d9c
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
See Also: 1421652
Target Milestone: --- → mozilla63
(Assignee)

Updated

9 months ago

Comment 3

9 months ago
Is manual QA needed on this bug? If yes, please provide a test webextension and some STRs, else add the "qe-verify-" flag.
Flags: needinfo?(e7358d9c)
(Assignee)

Comment 4

9 months ago
(In reply to Victor Carciu from comment #3)
> Is manual QA needed on this bug? If yes, please provide a test webextension
> and some STRs, else add the "qe-verify-" flag.

I don’t think it is, as I just reverted an incorrect change to two CSS selectors from bug 1354336.
Flags: needinfo?(e7358d9c) → qe-verify-
OS: Unspecified → All
Hardware: Unspecified → All
You need to log in before you can comment on or make changes to this bug.