Files without extension no longer open with associated application

RESOLVED DUPLICATE of bug 1465458

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1465458
2 years ago
10 months ago

People

(Reporter: mavegaart, Unassigned)

Tracking

({regression, regressionwindow-wanted})

55 Branch
Points:
---

Firefox Tracking Flags

(firefox57 fix-optional)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.101 Safari/537.36

Steps to reproduce:

1. Host a file (without a file extension!) with a custom mime type, e.g. application/x-test.
2. Associate the custom mime type application/x-test with notepad.exe.
3. Click the download link for the file.

(I use this method with print.exe to send raw printer commands to an industrial barcode printer)



Actual results:

The file is downloaded, but is not opened in Notepad.



Expected results:

The file should download and open in Notepad.

This worked in Firefox 54, but no longer in 55. Files with a file extension work fine in both versions.
Component: Untriaged → File Handling

Comment 1

2 years ago
I can confirm that this is exactly as reported. Works fine in v54, stopped working in v55. Please prioritize this issue!
The downloaded file cannot be opened with the selected application even manually. And neither if the setting is ask me every time. Nothing happens at the point when the file should be opened (other than a nice blinking animation).
Duplicate of this bug: 1394775

Updated

a year ago
Priority: -- → P3

Updated

10 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1465458
You need to log in before you can comment on or make changes to this bug.