Last Comment Bug 139174 - (PluginDocWin32) Plugin documentation for Win32
(PluginDocWin32)
: Plugin documentation for Win32
Status: RESOLVED FIXED
: helpwanted
Product: Developer Documentation
Classification: Other
Component: General (show other bugs)
: unspecified
: All Windows 2000
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://plugindoc.mozdev.org/windows.html
Depends on: 168889 133567 167199 182106
Blocks: PluginDoc
  Show dependency treegraph
 
Reported: 2002-04-22 05:46 PDT by Michael Hendy (Hendikins)
Modified: 2012-12-28 15:38 PST (History)
10 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Report - I tested several NC 4.79 plugins with Mozilla build 2002052306 (4.26 KB, application/octet-stream)
2002-06-07 15:44 PDT, Jeff D. Hanson
no flags Details

Description Michael Hendy (Hendikins) 2002-04-22 05:46:53 PDT
I'm working on it, and even tonight I've encountered one user who has needed it...
Comment 1 Michael Hendy (Hendikins) 2002-04-22 05:49:00 PDT
Assigning to myself, naturally, since I'm working on it.

This bug is for WINDOWS Plugin documentation only, bug 104506 is the general bug

Adding dep. to Bug 104506 (Working plug-ins status and files needed for Mozilla)
Comment 2 rudman 2002-04-22 10:31:10 PDT
CCing Oeschger. Michael/Ian, you might want to coordinate efforts.
Comment 3 Michael Hendy (Hendikins) 2002-04-22 12:04:52 PDT
PluginDoc One Point Oh is up. It's 5am, so if you can find something other than
nitpicking my grammar that needs to be done, I'm all ears.
Comment 4 Wouter van Wijk 2002-05-04 03:05:36 PDT
Isn't it possible to create a script that runs inside Moz and searches the
harddrive or certain default plugin-directories for possible plugins? I would
really like that.
Comment 5 Bernard Alleysson 2002-05-05 21:40:29 PDT
Now that bug 133282 is fixed, there's no need to copy plug-ins dll for popular
plug-ins.
What do you think ?
Comment 6 Michael Hendy (Hendikins) 2002-05-06 02:10:08 PDT
I think the document still has a purpose, because:

a. Not all plugins are going to be scanned for
b. Scanning for them doesn't help you much if you didn't have them installed in
the first place, and don't have a copy of 4.x (or 6.x)...
Comment 7 Alvaro Munoz-Aycuens 2002-05-06 06:00:10 PDT
Agree on that still ppl need to know which plugin works and how to install them,
and AFAIK you still need the registry hack to get it to work.
Comment 8 King-On Yeung 2002-05-11 22:25:49 PDT
It would be useful to provide a link
http://sdc.shockwave.com/shockwave/download/alternates for macromedia flash and
shockwave plugins. There are revisions/bug fix from time to time.
Comment 9 King-On Yeung 2002-05-11 22:31:45 PDT
For Java Runtime Environment plugins, other NP*.dll are needed to be copied as
well so that mime-type of application/x-java-applet;version=x.x are supported.
Comment 10 King-On Yeung 2002-05-12 22:40:56 PDT
Oh, i am wrong. there is no need to copy any java plugin dll (NPOJI610.DLL and
other NP*.dll) to plugins folder for 1.0rc2 and current nightly builds. (it
works at least for j2se 1.4).
Comment 11 Dean Tessman 2002-05-18 12:10:53 PDT
Should we add what bug 45699 added?  I don't think many people know they can put
their plugins in appdata\mozilla\plugins.
Comment 12 Olivier Cahagne 2002-06-06 03:04:18 PDT
I successfully ran Cisco IP/TV plug-in v.3.2 with Mozilla 2002060508 on Win2k
(trunk). Note that WinXP is not supported yet for IP/TV (will be in v.3.4).
Public page:
http://www.cisco.com/go/iptv
Download from here (need a CCO login):
http://www.cisco.com/cgi-bin/tablebuild.pl/iptv
Briefy, IP/TV plugin allows Mozilla to stream videos using Multicast, QoS, etc.
from an IP/TV server.
Comment 13 Jeff D. Hanson 2002-06-07 15:44:53 PDT
Created attachment 86870 [details]
Report - I tested several NC 4.79 plugins with Mozilla build 2002052306

WinZip 8.1 file.  I also emailed this to plugindoc@mozdev.org but I wanted to
make sure someone saw it.  If you get it twice, I won't bill you for the
duplicate :)
Comment 14 Jeff D. Hanson 2002-06-07 15:59:06 PDT
I missed one:

Pop-Up Stopper 2.8 Free - PARTIAL SUCCESS

Info:
http://www.panicware.com/popupstopper.html

Install:
http://www.panicware.com/product_downloads.html
http://www.popupstopper.net/PopUpStopper.exe

Test:   Any web site with pop-up ads.
PASSED tests but can't differentiate between undesired and required pop-ups.  If
browser is open, PUSF will block opening the mail window.  To bypass PUSF
temporarily, hold the CTRL key down when intentionally opening another window or
instance.
Comment 15 Olivier Cahagne 2002-07-13 08:21:39 PDT
Audio plugin (x-nap) (from Unisys) that work with Orange (mobile operator)
services (used to listen the voice message left on your mobile phone):
http://www.orange.fr/M2/apps/download/fr/Plug-in_ma_messagerie_vocale_Orange.exe
Comment 16 Dominik Stadler 2002-07-26 04:02:19 PDT
The following plugins are now available that improve working with Mozilla a lot:
- QuickTime Plug-in 6.0
- Macromedia Flash

There was an article on mozillazine.org at
http://www.mozillazine.org/articles/article2351.html that describes all about
them. I think the documentation should be updated accordingly.

The documentation at plugindoc.mozdev.org does not yet inform about these plugins.
Comment 17 rudman 2002-07-26 09:25:13 PDT
-->reassigning from me to Ian.

Ian, could you please assess what needs to be done to the NS plugin doc and
coordinate any Moz effort with M Hendy? Thanks.
Comment 18 Michael Hendy (Hendikins) 2002-07-26 11:36:36 PDT
Well, I'm usually in #Documentation and #Mozdev on irc.m.o as "Hendikins"...
Comment 19 Aleksander Adamowski 2002-08-01 23:33:50 PDT
Regarding comment #16:
The Flash 6 installer forgets to install flashplayer.xpt for Mozilla - it only
installs it in Netscape 6/7 components dir (see bug 160511)
The symptom is getting a "plugin.SetWindow is not a function" error in
JavaScript console when a plugin tries to execute JavaScript code of its HTML
document.

To correct that, one has to get hold of flashplayer.xpt (e.g. by installing
Netscape 6, installing Flash Player 6, and getting flashplayet.xpt from
Netscape's components dir) and placing it in Mozilla's plugins dir.
Comment 20 Michael Hendy (Hendikins) 2002-08-06 08:06:32 PDT
There's only so much I can test with VMware.

Assigning to self, and adding helpwanted keyword, since I can't test all these
things (even if I can work out how to get them installed).
Comment 21 Michael Hendy (Hendikins) 2002-08-06 08:07:39 PDT
er, assigning to SELF. bad bugzilla!
Comment 22 Michael Hendy (Hendikins) 2002-08-06 08:09:18 PDT
(sorry for spam)
Comment 23 M. Creidieki Crouch 2003-04-27 00:36:38 PDT
This web page is really badly designed.  I was trying to find information on how
to uninstall Shockwave Flash plugins, so I clicked on the thing that said it
would give me plugin documentation, and then I said I wanted Windows
documentation and I ended up at this feedback form.  You should really redesign
these web pages to make them useable if you want people to be able to find
anything.  It's really confusing and disheartening.
Comment 24 Jeff Mercer 2004-06-24 20:35:12 PDT
Succesfully got Citrix ICA Web Client plugin to work with Mozilla v1.5 and
Mozilla 1.7. The plugin install doesn't appear to recoginize Mozilla, but it is
compatible. You need to do a manual install process.

a) Install ica32t.exe (You should have this if you use a Citrix server)
b) Copy "npican.dll" from "c:\program files\citrix\icaweb32" to the Mozilla
plugins folder
c) Copy "npicanui.dll" from "c:\program files\citrix\icaweb32\resource\en" to
the Mozilla plugins folder
d) Quit and re-start Mozilla
Comment 25 Sumeet Singh 2006-01-02 08:22:49 PST
Java Plugin won't work with Firefox 1.5. I have tried with JRE 1.4_2 and 1.5. After a lot of searches and hunches I managed to get it to work by installing Mozilla 1.7.12 side-by-side. The reason for the problem is as follows and should be documented on the Plugin Documentation:

1. JRE provides plugins support for Mozilla/Netscape - not Firefox.
2. I went to Control Panel -> Java (or Java Plugin), and tried to enable plugin-support for Mozilla/Netscape but that didn't work when Mozilla was not installed on my laptop (i.e. only Firefox was installed). JRE complained that Mozilla/Netscape wasn't installed. I am guessing that's because Firefox 1.5 does not register itself as Mozilla (perhaps it registers as Firefox). And since JRE only looks for Mozilla - which it doesn't find in the registry - it thinks that Mozilla is not installed and therefore doesn't enable applet support for Firefox.
3. So then I installed Mozilla 1.7.12 as well. After that I went back to Control Panel -> Java and this time I was able to enable Mozilla/Netscape (i.e. I was able to check the box against Mozilla/Netscape in the Java control panel).

From the above, I am guessing that java applets won't run on *anybody's* computer as long as Firefox 1.5 does not fix this problem. I read elsewhere on the internet that people are facing similar problems for other platforms too (e.g. Solaris 9).
Comment 26 Kevin Brosnan 2009-09-22 05:38:40 PDT
This bug does not seem to be tracking plugindoc.mozdev.org work any more. Hendy has done several revamps since 2004. If you disagree with this closing please reopen.

Note You need to log in before you can comment on or make changes to this bug.