Closed Bug 1391756 Opened 2 years ago Closed 10 months ago

Intermittent dom/tests/mochitest/fetch/test_readableStreams.html | Test timed out.

Categories

(Core :: DOM: Core & HTML, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- fixed
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jorendorff)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell unknown])

Attachments

(1 file)

Duplicate of this bug: 1391785
Duplicate of this bug: 1391824
24 failures in the last 4.5 days:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1391756

android and windows 10 are the primary failure patterns, I think the increase is android.

:gbrown, sorry to keep adding things to your list- this seems to fall into a pattern like many of the other android failures- is this something you could add to your general list of android failures and maybe a root cause will be obvious?
Flags: needinfo?(gbrown)
Whiteboard: [stockwell needswork]
I don't see an obvious connection to other current Android issues.

This is a new-ish test added in bug 1128959.

:bkelly/:baku -- Can you have a look / see if you can make this test more reliable?
Flags: needinfo?(gbrown)
Flags: needinfo?(bkelly)
Flags: needinfo?(amarchesini)
Blocks: streams
I'll defer to baku here.
Flags: needinfo?(bkelly)
Jet, here's another potentially-related-to-Stylo intermittent failure.
Flags: needinfo?(bugs)
(In reply to Andrew Overholt [:overholt] from comment #12)
> Jet, here's another potentially-related-to-Stylo intermittent failure.

(In reply to Geoff Brown [:gbrown] from comment #7)
> By the way,
> https://treeherder.mozilla.org/#/jobs?repo=autoland&filter-
> searchStr=android%20mochitest-
> 35&tochange=2d61e13b6032faa42a9f11e84b8e7a23daae842c&fromchange=3942e9db3da30
> 4e63113ab3695a4d3348b375412 suggests this started failing on Android with
> bug 1382377 (or perhaps the previous servo merge?).

Stylo is not yet enabled for Android.
Flags: needinfo?(bugs)
Priority: -- → P2
Flags: needinfo?(amarchesini)
Blocks: streams-meta
Blocks: streams-ship
No longer blocks: streams-enable
This very rare timeout should not block streams from shipping.
No longer blocks: streams-ship
There are four occurrences that still have logs available. In all four, this happens after:

> JavaScript error: http://mochi.test:8888/tests/dom/tests/mochitest/fetch/common_readableStreams.js, line 26: TypeError: iframe.runTest is undefined; can't access its "call" property

I see two possibilities here.

1. The iframe races with the tests. If the tests reach this line of code before the iframe is finished loading, we get this error. Usually the iframe wins the race and we're fine.

2. Something is actually causing the iframe to fail to load.
Also removes an infinite regress of nested iframes. The original problem was
that tests would start running before the child iframe was done loading. The
straightforward fix is to have the child frame start the test. But this caused
further error messages because the child iframe is loaded more than once;
removing the iframe from the iframe fixes this.
Pushed by jorendorff@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7180b12513ad
Try to fix rare timeout in dom/tests/mochitest/fetch/test_readableStreams.html. r=baku
https://hg.mozilla.org/mozilla-central/rev/7180b12513ad
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Assignee: nobody → jorendorff
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.