Closed Bug 1389628 (streams-enable) Opened 2 years ago Closed 10 months ago

[meta] enable streams API by default in Nightly

Categories

(Core :: DOM: Core & HTML, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED

People

(Reporter: bkelly, Assigned: jorendorff)

References

(Blocks 6 open bugs)

Details

(Keywords: dev-doc-complete, meta)

Attachments

(2 files)

Meta bug tracking work to do before we can enable and ship.
Priority: -- → P1
No longer blocks: 1385890, 1387503
Depends on: 1385890, 1387503
Depends on: 1395220
Depends on: 1391756
meta = P3
Keywords: meta
Priority: P1 → P3
At Facebook we've recently shipped a video playback implementation using Streams for browsers that support it. Would love to see Streams shipped by default in Firefox, too!
Depends on: 1455811
It seems that Edge, Chrome and Safari support streams already. Would be great to see this feature shipped in Firefox.
Hey, just adding that we (Peer5) would also love to have this. In general in the video world (not just facebook) streaming fetch is really important and useful and is one of the largest missing capabilities in order for browsers to be as performant as native solutions.

At the moment we have to only ship the improved user experience to Chrome users which I find unfortunate. I'd also be happy to share more information about how streaming fetch is used for video delivery.
This also seems to be the root cause for bug 1479209 (that is, Google is already using streams with serviceworkers for their tier-1 experience).

Andrew, has this fallen off the radar?
Flags: needinfo?(overholt)
Nope, the only blocker (or at least the main one I know of) is bug 1385890 and Jason's working on it. Hoping to ship soon.
Flags: needinfo?(overholt)
Good to know, Andrew! We're also depending on this for Test Pilot's Send product.
Depends on: 1486698
Blocks: 1457500
Depends on: 1445854, 1496099
Depends on: 1491939
Depends on: 1499813
Depends on: 1501734
Depends on: 1502028
Keywords: leave-open
Pushed by jorendorff@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/03a1030b787f
Part 1: Fix a trivially broken jit-test. r=tcampbell
Blocks: 1502355
Depends on: 1501502
Depends on: 1504492
Summary: [meta] enable streams API by default → [meta] enable streams API by default in Nightly
Blocks: streams-meta
No longer depends on: 1387503
No longer depends on: 1391756
No longer depends on: 1504492
Pushed by jorendorff@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b3ccdaea275b
Part 2: Enable Streams API by default. r=baku,tcampbell
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Assignee: nobody → jorendorff
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.