Back button does not behave correctly with complex framesets

VERIFIED DUPLICATE of bug 36547

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 36547
16 years ago
13 years ago

People

(Reporter: Horst Prillinger, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

With some complex framesets, for example those at http://derstandard.at/, the
back and forward buttons don't work as expected. Instead they will ignore
certain pages and jump directly to a different web page called previously.

Reproducible: Always
Steps to Reproduce:
1. Go to any website, e.g. http://www.somewhere.org/
2. Go to http://derstandard.at/
3. Click on any link in the main news window. This will take you to a news article.
4. Click the "Back" button.


Actual Results:  When clicking the "Back" button, Mozilla goes back to
http://www.somewhere.org/

Expected Results:  Mozilla should have displayed the previous page, i.e.
http://derstandard.at/

If you click on the "Forward" button after step 4 above, you will not be taken
forward one step to http://derstandard.at/, but two steps to the news article.
For some reason the page at http://derstandard.at/ is being ignored by the Back
and Forward buttons.
dup of 36547

*** This bug has been marked as a duplicate of 36547 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.