stylo: Crash in alloc::oom::oom | std::collections::hash::map::HashMap<T>::resize<T> | std::collections::hash::map::HashMap<T>::entry<T> | style::selector_map::SelectorMap<T>::insert<T>

RESOLVED DUPLICATE of bug 1390838

Status

()

Core
CSS Parsing and Computation
P2
critical
RESOLVED DUPLICATE of bug 1390838
8 months ago
8 months ago

People

(Reporter: marcia, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

Trunk
Unspecified
Windows 10
crash
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 affected, firefox57 affected)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-cb3e453d-5135-4b57-8d9a-656330170820.
=============================================================

Seen while looking at crash stats - crashes go back to 20170731175927 when Nightly was still in 56: 24 crashes, 17 installations so far: http://bit.ly/2ij2hc2

URLs:

https://www.google.com/search?q=Harounian&ie=utf-8&oe=utf-8
https://www.rarbg.to/torrents.php?category=1;18;41;49
Some Gmail URLs
Unfortunately this is using the stdlib map, so it doesn't look like there's any annotation of what the OOM allocation size is.
I think this is a dupe of Servo_StyleSet_FlushStyleSheets bug 1390838.
Blocks: 1388178
Status: NEW → RESOLVED
Last Resolved: 8 months ago
status-firefox55: --- → unaffected
status-firefox-esr52: --- → unaffected
OS: Windows 7 → Windows 10
Priority: -- → P2
Resolution: --- → DUPLICATE
Duplicate of bug: 1390838
You need to log in before you can comment on or make changes to this bug.