stylo: crash in geckoservo::glue::Servo_StyleSet_FlushStyleSheets

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
P3
critical
RESOLVED WORKSFORME
10 months ago
7 months ago

People

(Reporter: darkspirit, Unassigned)

Tracking

(Blocks: 1 bug, {crash, nightly-community})

Trunk
Unspecified
Windows
crash, nightly-community
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 affected, firefox57 wontfix, firefox58 affected, firefox59 unaffected)

Details

(crash signature)

(Reporter)

Description

10 months ago
(Jan Andre Ikenmeyer [:darkspirit] from bug 1379585 comment 14)
> This bug was fixed exactly a month ago.
> 
> There are 7 crashes with this signature since 2017-08-15 04:46:18 again.
> [@ geckoservo::glue::Servo_StyleSet_FlushStyleSheets ]
> 57.0a1: 20170815100349 and 20170814100258
> https://crash-stats.mozilla.com/signature/?signature=geckoservo%3A%3Aglue%3A%3AServo_StyleSet_FlushStyleSheets&date=%3E%3D2017-08-02T05%3A53%3A08.000Z&date=%3C2017-08-16T05%3A53%3A08.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&_sort=-date&page=1#reports

(Emilio Cobos Álvarez [:emilio] from bug 1379585 comment 15)
> I think this deserves another bug, seems like a different stack.

(In reply to Emilio Cobos Álvarez [:emilio] from bug 1379585 comment 16)
> Huh, all of them seem related to print preview...
(Reporter)

Updated

10 months ago
Keywords: crash, nightly-community
Summary: stylo: crash in [@ geckoservo::glue::Servo_StyleSet_FlushStyleSheets ] → stylo: crash in geckoservo::glue::Servo_StyleSet_FlushStyleSheets
(Reporter)

Updated

10 months ago
Severity: normal → critical
Bug 1390951 is another set of Stylo crash reports related to print preview.
Priority: -- → P3
See Also: → bug 1390951
P3 because there are only about a dozen crash reports. The earliest crash report I see is from build id 20170814100258 on 2017-08-15, so this might be a recent regression. I don't see any crash reports from Beta 56 yet.
status-firefox55: --- → unaffected
status-firefox56: --- → ?
status-firefox-esr52: --- → unaffected
Over the past week, there have been 21 instances of this crash signature from 18 different users.
Roughly half of crashes are from FlushUserFontSet, which I suspect to be the same issue as bug 1385925. Others seems to be related to anonymous node and / or print.
Crash Signature: [@ geckoservo::glue::Servo_StyleSet_FlushStyleSheets ] → [@ alloc::oom::oom | std::collections::hash::map::HashMap<T>::resize<T> | std::collections::hash::map::HashMap<T>::entry<T> | style::selector_map::SelectorMap<T>::insert<T>] [@ geckoservo::glue::Servo_StyleSet_FlushStyleSheets]
status-firefox56: ? → affected
OS: Windows 10 → Windows
Duplicate of this bug: 1392309
Depends on: 1395064
status-firefox57=wontfix unless someone thinks this bug should block 57
status-firefox57: affected → wontfix
This crash has gone away. There were only three reports from 58 and none from 59 so far.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
status-firefox58: --- → affected
status-firefox59: --- → unaffected
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.