Closed Bug 1392316 Opened 4 years ago Closed 4 years ago

Crash in mozilla::layers::WebRenderLayerManager::ClearCachedResources

Categories

(Core :: Graphics: WebRender, defect)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
mozilla57
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected

People

(Reporter: marcia, Assigned: sotaro)

References

(Blocks 1 open bug)

Details

(Keywords: crash, Whiteboard: [gfx-noted])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-9684523a-d084-4ebf-8b93-16ef20170820.
=============================================================

Seen while looking at crash stats: http://bit.ly/2v7vubL. 8 installs, 14 crashes.
Blocks: wr-stability
See Also: → 1391262
Whiteboard: [gfx-noted]
Priority: P3 → P2
Whiteboard: [gfx-noted] → [wr-mvp] [gfx-noted]
Duplicate of this bug: 1398351
Assignee: nobody → sotaro.ikeda.g
Status: NEW → ASSIGNED
Priority: P2 → P1
Target Milestone: --- → mozilla57
There is a route to call TabParent::SetDocShellIsActive() from js. The call stack was like the following.

>	xul.dll!mozilla::dom::TabParent::SetDocShellIsActive(bool isActive) Line 2893	C++
 	xul.dll!XPTC__InvokebyIndex() Line 99	Unknown
 	xul.dll!XPCWrappedNative::CallMethod() Line 1282	C++
 	xul.dll!XPC_WN_GetterSetter() Line 957	C++
 	xul.dll!js::InternalCallOrConstruct() Line 495	C++
 	xul.dll!js::CallSetter() Line 688	C++
 	xul.dll!SetExistingProperty() Line 2755	C++
 	xul.dll!js::NativeSetProperty<1>() Line 2791	C++
 	xul.dll!SetPropertyOperation() Line 269	C++
 	xul.dll!Interpret() Line 2881	C++
 	xul.dll!js::RunScript() Line 435	C++
 	xul.dll!js::InternalCallOrConstruct() Line 516	C++
 	xul.dll!js::CallSetter() Line 688	C++
 	xul.dll!SetExistingProperty() Line 2755	C++
 	xul.dll!js::NativeSetProperty<1>() Line 2791	C++
 	xul.dll!SetPropertyOperation() Line 269	C++
 	xul.dll!Interpret() Line 2881	C++
 	xul.dll!js::RunScript() Line 435	C++
 	xul.dll!js::InternalCallOrConstruct() Line 516	C++
 	xul.dll!js::Call() Line 559	C++
 	xul.dll!JS::Call() Line 2965	C++
 	xul.dll!mozilla::dom::EventHandlerNonNull::Call() Line 260	C++
 	xul.dll!mozilla::dom::EventHandlerNonNull::Call<nsISupports * __ptr64>() Line 362	C++
 	xul.dll!mozilla::JSEventHandler::HandleEvent(nsIDOMEvent * aEvent) Line 216	C++
 	xul.dll!nsXBLPrototypeHandler::ExecuteHandler() Line 393	C++
 	xul.dll!nsXBLEventHandler::HandleEvent() Line 52	C++
(In reply to Marcia Knous [:marcia - use ni] from comment #0)
> This bug was filed from the Socorro interface and is 
> report bp-9684523a-d084-4ebf-8b93-16ef20170820.
> =============================================================

By the crash report, TabParent::SetDocShellIsActive(/* isActive */ true) seemed to be called before WebRenderLayerManager::Initialize() call.
(In reply to Sotaro Ikeda [:sotaro] from comment #3)
> (In reply to Marcia Knous [:marcia - use ni] from comment #0)
> > This bug was filed from the Socorro interface and is 
> > report bp-9684523a-d084-4ebf-8b93-16ef20170820.
> > =============================================================
> 
> By the crash report, TabParent::SetDocShellIsActive(/* isActive */ true)
> seemed to be called before WebRenderLayerManager::Initialize() call.

Correction:

By the crash report, TabParent::SetDocShellIsActive(/* isActive */ false)
> seemed to be called before WebRenderLayerManager::Initialize() call.
From the crash report, Bug 1399850 seems similar, but it has the following error like Bug 1399850 comment 8.

> >  "GraphicsCriticalError 	|[C0][GFX1-]: Failed to create WebRenderBridgeChild. (t=0.345005) "
See Also: → 1399850
See Also: → 1401849
The crash did not happen since Bug 1401849 fix.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Priority: P1 → --
Whiteboard: [wr-mvp] [gfx-noted] → [gfx-noted]
You need to log in before you can comment on or make changes to this bug.