WebExtensions: add browser.runtime.restartApp method

RESOLVED DUPLICATE of bug 1344786

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1344786
10 months ago
10 months ago

People

(Reporter: Geoffrey De Belie (Smile4ever), Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170813183258

Steps to reproduce:

To port https://addons.mozilla.org/en-US/firefox/addon/restart-manager/ there needs to be a way to restart Firefox. I propose the method browser.runtime.restartApp.
(Reporter)

Comment 1

10 months ago
Related:

Add a restart button similar to addons button provided in Firefox 57 Photon
https://bugzilla.mozilla.org/show_bug.cgi?id=1366009

Possibility to restartApplication from WebExtensions
https://bugzilla.mozilla.org/show_bug.cgi?id=1344786
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1344786
You need to log in before you can comment on or make changes to this bug.