Closed Bug 1366009 Opened 3 years ago Closed Last year

Add a restart button similar to addons button provided in Firefox 57 Photon

Categories

(Firefox :: Toolbars and Customization, enhancement)

55 Branch
enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: u595641, Unassigned)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows; Windows NT 5.1; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518030213

Steps to reproduce:

Firefox Photon theme already provides various buttons like addon button, cut,cop,paste etc.
So please add a restart button which like all buttons can be placed anywhere.

Firefox already has restart functionality in build so adding it will make it easier to use & test for users like me
Attached image 1.jpg
A button just like this will do, can be placed anywhere and makes it easier
Attachment #8869101 - Flags: ui-review?
Severity: normal → enhancement
Iteration: --- → 55.6 - May 29
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Component: Untriaged → Toolbars and Customization
OS: Unspecified → All
Priority: -- → P3
Hardware: Unspecified → All
Shift + F2, then type "restart" Enter. :P
I know that rfeeley has been interested in something like this as well - though what he suggested was something more akin to the Mac OS metaphor of showing more advanced menu items when holding down Alt.

So perhaps if the user is holding down Alt while clicking on the app menu button, we show a Restart option in the app menu? Just an idea.
Please avoid adding dependencies on the Photon metabugs. We're using them to track the work that we've picked or that we're likely to complete for 57. By all means, let's keep this bug around, but we need to be very deliberate about which ones we're going to commit to fixing for 57.
(In reply to Darkspirit from comment #2)
> Shift + F2, then type "restart" Enter. :P
I restart many times when testing webrender etc. and that is quite comfortably.

See: https://developer.mozilla.org/en/docs/Tools/Keyboard_shortcuts


(In reply to Mike Conley (:mconley) from comment #3)
> So perhaps if the user is holding down Alt while clicking on the app menu
> button, we show a Restart option in the app menu? Just an idea.

Alt = Show menu bar on Windows and Linux (don't know how Mac behaves). If then want to click on the burger menu, you will miss it and have to rearrange your mouse position.
Alt + Click on burger button = move window on KDE.
(In reply to Darkspirit from comment #2)
> Shift + F2, then type "restart" Enter. :P

yes that's why said it's in built :P
Just adding munu item  + button will improve it :)

(In reply to Mike Conley (:mconley) from comment #3)
> I know that rfeeley has been interested in something like this as well -
> though what he suggested was something more akin to the Mac OS metaphor of
> showing more advanced menu items when holding down Alt.
> 
> So perhaps if the user is holding down Alt while clicking on the app menu
> button, we show a Restart option in the app menu? Just an idea.

well on all platforms can press alt->file-restart about exit.
Plus adding a button like addon button currently in photon theme(attached image) , which can be placed anywhere and user can click it & comes in handy when testing.

(In reply to Mike Conley (:mconley) from comment #4)
> Please avoid adding dependencies on the Photon metabugs. We're using them to
> track the work that we've picked or that we're likely to complete for 57. By
> all means, let's keep this bug around, but we need to be very deliberate
> about which ones we're going to commit to fixing for 57.

Thought had to add if Photon related :) Sorry my bad.

Will adding a button entry be time taking? It should be in Firefox 57 IMO as it improves productivity+ rewriting of theme n customization is going on so this is a good time.
correct me if my assumptions are wrong.
Flags: needinfo?(mconley)
Flags: needinfo?(bugzilla)
(In reply to Sami from comment #6)
Please don't needinfo me for a regular comment. (I got an email anyway.) I am an user like you ;-) It's enough the fill the bug for the correct Product + Component, then the corresponding team + triage owner will get an email. If they think that this is very important you will see that the stone is rolling after days/weeks. Maybe more good arguments are needed. Votes from other users are an indicator if something is wanted. Maybe they just have to work on other bugs, before coming to this. Your suggestion is a good nice-to-have.
Flags: needinfo?(bugzilla)
Attached image 1.png
File menu
Attached image 2.jpg
Panel menu
(In reply to Darkspirit from comment #7)
> (In reply to Sami from comment #6)
> Please don't needinfo me for a regular comment. (I got an email anyway.) I
> am an user like you ;-) It's enough the fill the bug for the correct Product
> + Component, then the corresponding team + triage owner will get an email.
> If they think that this is very important you will see that the stone is
> rolling after days/weeks. Maybe more good arguments are needed. Votes from
> other users are an indicator if something is wanted. Maybe they just have to
> work on other bugs, before coming to this. Your suggestion is a good
> nice-to-have.

Alright mate :)
With photon coming up in 57 the timing is perfect & code already implemented Just adding menu item  + button will improve it :)
Depends on: 1366477
Priority: P3 → P2
Iteration: 55.6 - May 29 → ---
No longer depends on: 1366477
Priority: P2 → --
(In reply to Sami from comment #6)
> Will adding a button entry be time taking? It should be in Firefox 57 IMO as
> it improves productivity+ rewriting of theme n customization is going on so
> this is a good time.
> correct me if my assumptions are wrong.

It adds additional paths for testing, likely additional icon work, translation, etc. It's also not part of the current spec.

Thankfully, the Developer Toolbar exposes the restart functionality you appear to be looking for.
Flags: needinfo?(mconley)
(In reply to Mike Conley (:mconley) from comment #11)
> (In reply to Sami from comment #6)
> > Will adding a button entry be time taking? It should be in Firefox 57 IMO as
> > it improves productivity+ rewriting of theme n customization is going on so
> > this is a good time.
> > correct me if my assumptions are wrong.
> 
> It adds additional paths for testing, likely additional icon work,
> translation, etc. It's also not part of the current spec.
> 
> Thankfully, the Developer Toolbar exposes the restart functionality you
> appear to be looking for.

Actually no, UI buttons are easier to place in menu/UI/MoreToolsMenu

Plus there are users like me who have to press an additional button which is awkwardly placed to get to shift+F2(which most times does not work in if pages are loading or takes too long to appear :( )
Like the reporter said adding above the exit button in photon menu is easier 

I hope you guys implement it as it's easier to click than key-combo in this case.
Attachment #8869101 - Flags: ui-review?
It's worth noting that the request for a WE api for it was WONTFIXED by bug 1344786.
I think it is a reasonable utility, as we provide the Help - Restart with Add-ons Disabled… menu. If anyone thinks the button brings unreasonable implied for stability, it is reasonable to put the Help menu, but sacrifice the convenience and customizable.
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → 1344786, 1001747, 1156944
One aspect that may not have been considered here is that since it will no longer be possible to modify the interface with an add-on, making and sharing UI changes made to userChrome.css and userContent.css will become a much bigger focus for power users.

To see these changes, the browser needs to be restarted every time. I personally restart the browser just for this matter alone from anything between 3 to 20 times a day, sometimes more. I believe this is the main purpose for plenty of users today, and will become increasingly important once 57 lands.
As someone who mostly uses the mouse, only, I would not want to have to hold down (or click on On-screen keyboard) Alt to expose this functionality.  Perhaps a movable restart button would be better.  I don't think it would even need to be exposed to all users by default; it could just be in the customize panel and dragged wherever the user wanted.  A menu item right next to Exit would give this feature more exposure to users, though.

Currently, a legacy restart add-on is still working for me in Fx 57, but if this functionality cannot be a WE API, it should be built in, somehow. 

I use restart for userChrome.css changes, certain about:config changes, and a few other cases, and typically restart multiple times per day, not counting Nightly updates.  Restarting Fx is also the first-step advice most users are given if they run into any problem with Fx.
I am currently using a restart button add-on that will stop working when Firefox 57 ships. Please add this button as an option in the new Firefox theme.
Any news on adding this to default Firefox?
Any fix in the works?
or addon?
Flags: needinfo?(yfdyh000)
No, I have no more information.
Flags: needinfo?(yfdyh000)
Since bug1461970 the only method to restart browser after 57(comment #2) will disappear, is there still any chance adding a restart button or method?
They have provided an alternative to restart. It is available in Nightly since the 5th of May 2018:

    Win/Linux: Ctrl+Shift+J (open Browser Console) then Ctrl+Alt+R (restart the browser)
    Mac: ⌘⇧J, ⌘⌥R
(In reply to Krzysztof from comment #23)
> They have provided an alternative to restart. It is available in Nightly
> since the 5th of May 2018:
> 
>     Win/Linux: Ctrl+Shift+J (open Browser Console) then Ctrl+Alt+R (restart
> the browser)
>     Mac: ⌘⇧J, ⌘⌥R

Having a restart button in customize menu also above quit button in photon menu is far more convenient.
(In reply to Krzysztof from comment #23)
> They have provided an alternative to restart. It is available in Nightly
> since the 5th of May 2018:
> 
>     Win/Linux: Ctrl+Shift+J (open Browser Console) then Ctrl+Alt+R (restart
> the browser)
>     Mac: ⌘⇧J, ⌘⌥R

Being as this functionality already exists at a deeper level, what would it take for the developers to hook it up to the UI as an optional button for the overflow menu or as an item in the menu next the "Exit" button? The actual "Ctrl+Alt+R" conflicts with software tied to my graphics card drivers, so I can't even use that. This use to be a simple add-on before Firefox went Quantum.
[Tracking Requested - why for this release]:
it's been a year and no one clearly said yes or no?
Flags: needinfo?(aswan)
There was discussion of this (and some suggestions offered) on the firefox-dev mailing list, eg:
https://mail.mozilla.org/pipermail/firefox-dev/2018-March/006293.html

But ultimately, I'm not the person who would make such a decision, it would be the Firefox desktop UX team I suppose.
Flags: needinfo?(aswan)
Sorry if the needinfo is for the wrong person but it would be nice if someone could tell us if this is planned to be implemented or if they are going to talk about it or something.
Flags: needinfo?(hhsu)
(In reply to larabe from comment #30)
> Sorry if the needinfo is for the wrong person but it would be nice if
> someone could tell us if this is planned to be implemented or if they are
> going to talk about it or something.

is it that hard to implement?
now even more so after dev bar restart gone
(In reply to saproeno from comment #31)
> (In reply to larabe from comment #30)
> > Sorry if the needinfo is for the wrong person but it would be nice if
> > someone could tell us if this is planned to be implemented or if they are
> > going to talk about it or something.
> 
> is it that hard to implement?
> now even more so after dev bar restart gone

larabe just set the needinfo flag to someone who's not active on Bugzilla for many months. So I forward the needinfo to Gijs, who's set as the triage owner. Maybe he can answer this.

Sebastian
Flags: needinfo?(hhsu) → needinfo?(gijskruitbosch+bugs)
There are already a lot of ways to do this:

- quit the browser, reopen it, click 'restore session' (or just have it set to auto-restore...)
- the browser console shortcuts as discussed in comment 23
- open (and/or create a bookmark for) about:restartrequired, click the restart button
- open (and/or create a bookmark for) about:profiles, click the restart button there
- after bug 1449966 is fixed, maybe also via about:support and/or about:config .
(about:config and so on are nicer for this anyway, because they're contextual. You don't need space for that button all the time, but you may need to restart to get changes to specific preferences to take effect.)

- for everyone using userChrome.js/userChrome.css to alter things anyway - add your own button?


I don't think there's enough value to adding Yet Another Way of doing this to justify implementing it.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.